Укажите связывающее отношение для пары объектов: Клавиатурный тренажёр и программа «Руки солистов» ... клавиатурного тренажёра. 1) Является элементом множества 2) входит в состав 3) является разновидностью
Program Ves; Var a1,a2,a3,a4,t1,t2,t3,p,d,vp,b: Integer; begin writeln ('программа вычисляет норму для данного ученика'); writeln ('введи массу учебника 1');readln (a1); writeln ('введи массу учебника 2');readln (a2); writeln ('введи массу учебника 3');readln (a3); writeln ('введи массу тетради 1');readln (t1); writeln ('введи массу тетради 2');readln (t2); writeln ('введи массу тетради 3');readln (t3); writeln ('введи массу пенала');readln (p); writeln ('введи массу дневника');readln (d); writeln ('введи массу портфеля');readln(vp); b:=a1+a2+a3+a4+t1+t2+t3+p+d+vp;writeln ('общая масса портфеля= ' b); if (b<=5) then writeln ('норма') else writeln ('ненорма'); readln; end.
Марина
16.03.2020
Летающий автобус) 1. Мест в эконом-классе 120, а в бизнес-классе 40. 2. 100 процентов прибыли получим, если заполним все места. Билет в эконом-классе стоит в 2 раза меньше чем X. Получаем следующее уравнение: 40*X + 0.5*120*X = 100%, X = 1% от всей прибыли. Значит один билет в бизнес - классе приносит один процент прибыли. А один билет в эконом-классе приносит 0.5 процента прибыли. 3. Осталось рассчитать прибыль компании учитывая непроданные билеты: P = 100 - b - 0.5*a и написать программу:
var a,b:integer; begin repeat writeln('Введите количество непроданных билетов (a,b)'); readln(a,b); until (a<=120) and (b<=40)and (a>=0) and (b>=0); writeln('Прибыль компании составит ',100-b-0.5*a,'%'); end.