ВалерийАндреевна1788
?>

с информатикой. Эти программы нужно написать на Лампанели: а) Написать программу вычисляющую объем и площадь полной поверхности прямоугольного паралле­лепипеда со сторонами a, b, с.б) Дано двузначное натуральное число, записанное в десятичной системе счис­ления. Получите из него трехзначное число, записав в середину заданную цифру k.​

Информатика

Ответы

shangina1997507
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var n:=ReadInteger('n=');
  if n<0 then Writeln(n,'! не определено: n<0')
  else
    if n=0 then Writeln('0!=1')
    else begin
      var p:BigInteger:=1;
      for var i:=2 to n do p*=i;
      Writeln(n,'!=',p)
      end
end.

Тестовое решение:
n= 138
138!=691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
karnakova-a
Для решения определим 
1. Время передачи по высокоскоростному каналу
2. Время передачи по низкоскоростному каналу
3. Время для получения первых 1024 Кб
4. Всё сложим.

2^20 бит/с = 2^20 / 8 / 1024 Кбайт/с = 2^20 / 2^3 / 2^10 = 2^7 Кбайт/с
2^13 бит/с = 2^13 / 8 / 1024 Кбайт/с = 2^13 / 2^3 / 2^10 = 2^0 = 1 Кбайт/с
10 Мб равно 10*1024 Кбайт = 10*2^10 Кбайт.

По высокоскоростному каналу файл будет передаваться
(10*2^10) / 2^7 = 10*2^3 = 80 секунд

По низкоскоростному каналу файл будет передаваться
(10*2^10) / 1 = 10*2^10 = 10240 секунд.

Первые 1024 Кбайт будут передаваться
2^10 / 2^7 = 8 секунд

Общее время 80+10240+8 = 10328 секунд.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с информатикой. Эти программы нужно написать на Лампанели: а) Написать программу вычисляющую объем и площадь полной поверхности прямоугольного паралле­лепипеда со сторонами a, b, с.б) Дано двузначное натуральное число, записанное в десятичной системе счис­ления. Получите из него трехзначное число, записав в середину заданную цифру k.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

abramovae
Константиновна
ver2bit
tatianaavoronina66
osipovasalex5316
Tamara
Olgax732
Kolokolnikova DANIIL179
marinakovyakhova
vodexshop2
Abespal
yda659
natkuv7
Yuliya Aleksandr686
Svetlana1877