layna1241383
?>

Python В игре "Хлопок" все участники стоят в кругу. Ведущий определяет кто начинает игру и объявляет целое число. Дальше участники по часовой стрелке называют последующее число, но если это число делится на 3, то они просто производят хлопок.Напишите программу, которая на входе принимает два натуральных числа: a - начальное значение игры,  n - конечное значение. Для каждого из чисел в последовательности вывести слово "Хлопок", если число делится на 3, иначе вывести само число.Входные данные:Два целых числа a и n (a < n)Выводные данные:Результат вывода в столбик​

Информатика

Ответы

schumacher8

a, n = map(int, input().split())

for i in range(a + 1, n + 1):

   if i % 3 == 0:

       print("Хлопок")

   else:

       print (i)

irinanikulshina144

1. На ленте машины Тьюринга содержится последовательностью символов “+”. Напишите программу для машины Тьюринга, которая каждый второй символ “+” заменит на “–”. Замена начинается с правого конца последовательности. Автомат в состоянии q1 обозревает один из символов указанной последовательности. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

2. Дано число n в восьмеричной системе счисления. Разработать машину Тьюринга, которая увеличивала бы заданное число n на 1. Автомат в состоянии q1 обозревает некую цифру входного слова. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

3. Дана десятичная запись натурального числа n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

4. Дано натуральное число n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1, при этом в выходном слове старшая цифра не должна быть 0. Например, если входным словом было “100”, то выходным словом должно быть “99”, а не “099”. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

5. Дан массив из открывающих и закрывающих скобок. Построить машину Тьюринга, которая удаляла бы пары взаимных скобок, т.е. расположенных подряд “( )”.

Например, дано “) ( ( ) ( ( )”, надо получить “) . . . ( ( ”.

Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

6. Дана строка из букв “a” и “b”. Разработать машину Тьюринга, которая переместит все буквы “a” в левую, а буквы “b” — в правую части строки. Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

Попов1946

1. Бумажный носитель помещается в сканер.

2. В программе отдаётся команда Сканировать.

Создаётся цифровая копия исходного документа в формате docx.

3. Программа распознавания текста анализирует структуру документа, выделяя на его страницах блоки текста, таблицы, картинки и т. п. Строки разбиваются на слова, а слова — на отдельные буквы. После этого программа сравнивает найденные символы с шаблонными изображениями букв и цифр, хранящимися в её памяти. Программа рассматривает различные варианты разделения строк на слова и слов на символы. В программу встроены словари, обеспечивающие более точный анализ и распознавание, а также проверку распознанного текста. Проанализировав огромное число возможных вариантов, программа принимает окончательное решение и выдает пользователю распознанный текст.

4. Распознанный текст переносится в окно текстового редактора, в котором пользователь может редактировать и форматировать распознанный текст.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Python В игре "Хлопок" все участники стоят в кругу. Ведущий определяет кто начинает игру и объявляет целое число. Дальше участники по часовой стрелке называют последующее число, но если это число делится на 3, то они просто производят хлопок.Напишите программу, которая на входе принимает два натуральных числа: a - начальное значение игры,  n - конечное значение. Для каждого из чисел в последовательности вывести слово "Хлопок", если число делится на 3, иначе вывести само число.Входные данные:Два целых числа a и n (a < n)Выводные данные:Результат вывода в столбик​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Роман_Гречина
Надья-Олеговна
Lesnova_Kiseleva730
linda3930
snabomp
Olenkalebedeva4477
informalla
amaraks67
NatalyaAlekseevich1644
chizhenkovd9
Reginahappy
TatiyanaBe20135263
picsell
dpolkovnikov
Anatolevich_Kulikov1229