Дмитрий192
?>

Тройки чисел(в c++) Напишите программу, находящую количество троек целых чисел a, b, p таких, что p — простое число, числа удовлетворяют равенству: 3 и каждое из чисел a, b и p лежит в промежутке от N до M (то есть N≤a≤ M, N≤b≤ M, N≤p≤ M Входные данные Вводятся два целых числа N и M (0≤N≤M≤100000) Выходные данные Выведите искомое количество троек чисел a, b, p. заранее

Информатика

Ответы

uttgroup

import math

p = int(

b = false

for i in range(1, p ** 2):

    gip = (p ** 2) + (i ** 2)

    if math.sqrt(gip) % 1 == 0:

        b = true

        if int(math.sqrt(gip)) ! = p:

            print(int(math.sqrt(

if b == false:

    print(-1)

# что-то типо этого, но не проходит по времени. надо смотреть диапазон. может если кто дорешает, ответьте. а так всё норм работает)

cochana

1)  письмо-то было иероглифическое. чтобы выучить все иероглифы, нужно было обладать недюжинным терпением, хорошей памятью. а это как раз свойственно мудрым людям.

2)  основными предметами в школе были письмо, грамота и счет, обучали гимнастическим , плаванию и хорошим манерам.

3)сначала писали на черепках глиняной посуды. когда ученик овладевал письмом, ему давали для письма папирус. писали тонкой тростниковой палочкой, используя черную и красную краски. 

4) профессия писца считалась престижной и доходной, они были частью двора фараонов и освобождались от уплаты налогов, службы в армии и какой бы то ни было работы.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Тройки чисел(в c++) Напишите программу, находящую количество троек целых чисел a, b, p таких, что p — простое число, числа удовлетворяют равенству: 3 и каждое из чисел a, b и p лежит в промежутке от N до M (то есть N≤a≤ M, N≤b≤ M, N≤p≤ M Входные данные Вводятся два целых числа N и M (0≤N≤M≤100000) Выходные данные Выведите искомое количество троек чисел a, b, p. заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatasi
verav75
Reutskii884
Valentina1520
siyaniemoskva
tokarevaiv
pavlovm8316
elenarumack
Д.О. Игорь
alexeytikhonov
testovvanya
miumiumeaow
Rjkjneirbyf555
An-solomon