morozmd
?>

Напишите программу, которая по возрасту и полу человека, определяет является ли он военнообязанным (мужчина – военнообязанный; женщина - невоеннообязанная Все входные данные проверять на правильность ввода.

Информатика

Ответы

Alyona

Объяснение:

Program voennie;

Var pol, vozrast :integer ;

Begin

Writeln (Напишите Ж если вы женщина и М если мужчина) ;

Readln (pol) ;

Writeln(Напишите ваш возраст) ;

If (pol=М) and (vozrast=16) then writeln(Вы военнообязанный)

Else writeln (Вы не военнообязанный) ;

end.

Elizavetaborisovna1992

Язык программирования — формальный язык, предназначенный для записи компьютерных программ. Язык программирования определяет набор лексических, синтаксических и семантических правил, определяющих внешний вид программы и действия, которые выполнит исполнитель (обычно — ЭВМ) под её управлением.

Языки программирования делятся на два класса - МАШИННО-ЗАВИСИМЫЕ и МАШИННО-НЕЗАВИСИМЫЕ. Под машинно-зависимыми языками понимают языки, алфавит, синтаксис и семантика которых зависят от системы команд процессора конкретно используемой ЭВМ. Машинно-независимые языки - языки свободные от такой зависимости.

Транслятор — программа или техническое средство, выполняющее трансляцию программы. Трансляция программы — преобразование программы, представленной на одном из языков программирования, в программу на другом языке.

интерпретатор - вид транслятора, осуществляющего пооператорную (покомандную) обработку и выполнение исходной программы или запроса (в отличие от компилятора, транслирующего всю программу без её выполнения).

основные задачи любой транслятор выполняет следующие основные задачи: анализирует транслируемую программу, в частности определяет содержит ли она синтаксические ошибки, и генерирует выходную программу на языке машинных команд и распределяет память для объектной программы.

Информация взята с интернета (отправил ответ что-бы вы не искали по отдельности)

maximovpavel9114
Program task5; 
  var v:string; ch,p:integer; 
begin 
  writeln('Введите число');
  readln (ch); 
  case ch of 
    1: v:= ('один'); 
    2: v:= ('два'); 
    3: v:= ('три');
    4: v:= ('четыре');
    5: v:= ('пять');
    6: v:= ('шесть');
    7: v:= ('семь');
    8: v:= ('восемь');
    9: v:= ('девять');
    10: v:= ('десять'); 
    11: v:= ('одиннадцать');
    12: v:= ('двенадцать');
    13: v:= ('тринадцать');
    14: v:= ('четырнадцать');
    15: v:= ('пятнадцать');
    16: v:= ('шестнадцать');
    17: v:= ('семнадцать');
    18: v:= ('восемнадцать');
    19: v:= ('девятнадцать');
    20: v:= ('двадцать' );
    21,22,23,24,25,26,27,28,29: begin p:=(ch mod 10); v:= ('двадцать' ); end;
    30: v:= ('тридцать ');
    31,32,33,34,35,36,37,38,39: begin p:=(ch mod 10); v:= ('тридцать' ); end;
    40: v:= ('сорок');
    41,42,43,44,45,46,47,48,49: begin p:=(ch mod 10); v:= ('сорок' ); end;
    50: v:= ('пятьдесят ');
    51,52,53,54,55,56,57,58,59: begin p:=(ch mod 10); v:= ('пятьдесят' ); end;
    60: v:= ('шестьдесят '); 
    61,62,63,64,65,66,67,68,69: begin p:=(ch mod 10); v:= ('шестьдесят' ); end;
    70: v:= ('семьдесят ');
    71,72,73,74,75,76,77,78,79: begin p:=(ch mod 10); v:= ('семьдесят '); end;
    80: v:= ('восемьдесят '); 
    81,82,83,84,85,86,87,88,89: begin p:=(ch mod 10); v:= ('восемьдесят' ); end;
    90: v:= ('девяносто ');
    91,92,93,94,95,96,97,98,99: begin p:=(ch mod 10); v:= ('девяносто ' ); end;
    100: v:=('сто'); 
  end; 
  writeln(v,p); 
end.

Так оно по крайней мере запускается. Но нет обработки переменной p, по ней надо делать отдельный case of.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая по возрасту и полу человека, определяет является ли он военнообязанным (мужчина – военнообязанный; женщина - невоеннообязанная Все входные данные проверять на правильность ввода.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

askorikova
Alisa
silviya
elivanova
Владимирович
Бирюков Карпова1379
catmos
Korobeinikov-Yulich23
mihalewanadia20176987
Белов_Лукина1339
Информатика 9 класс паскаль
МАМОНОВА-андрей
krutikovas
Maionova
cheshirsky-kot
miumiumeaow