Aleks0091
?>

5.1. С одного дерева сняли Х груш, а со второго 5 мальчиков, каждый из которых сидя на дереве, съел по 17 груш. После этого со второго дерева сняли еще Ү груш. Составитьпрограмму, которая определит, сколько груш было на обоих деревьях.Входные данные: 65 45Выходные данные: 195​

Информатика

Ответы

shelep19789
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=''+
         '';
  foreach var c in s do Writeln(c,' ',ORDANSI(c))
end.

Результат
А 192
Б 193
В 194
Г 195
Д 196
Е 197
Ё 168
Ж 198
З 199
И 200
Й 201
К 202
Л 203
М 204
Н 205
О 206
П 207
Р 208
С 209
Т 210
У 211
Ф 212
Х 213
Ц 214
Ч 215
Ш 216
Щ 217
Ъ 218
Ы 219
Ь 220
Э 221
Ю 222
Я 223
а 224
б 225
в 226
г 227
д 228
е 229
ё 184
ж 230
з 231
и 232
й 233
к 234
л 235
м 236
н 237
о 238
п 239
р 240
с 241
т 242
у 243
ф 244
х 245
ц 246
ч 247
ш 248
щ 249
ъ 250
ы 251
ь 252
э 253
ю 254
я 255
Prostofil200790
//прога на Pascal`е
{не работает на  PascalABC.Net, т.к. оный использует 2-байтную кодировку Unicode, а не 1-байтную кодировку ASCII, как более ранние версии Pascal`ей}
const
n = 32*2;
var
ch: array [1..n] of byte;
i, num: byte;
begin
num:=192;
for i:=1 to n do
begin
ch[i]:=num;
inc (num);
end;

writeln ('Символ   |   Код ASCII');
writeln ('');
for i:=1 to n do writeln ('   ', chr(ch[i]), '     |    ', ch[i]);end.

{версия для PascalABC.Net}
//прога на Pascal`е
const
n = 32*2;
var
ch: array [1..n] of byte;
i, num: byte;
begin
num:=192;
for i:=1 to n do begin
ch[i]:=num;
inc (num);
end;

writeln ('Символ   |   Код ASCII');
writeln ('');
for i:=1 to n do writeln ('   ', chr(ch[i]+848), '     |    ', ch[i]);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

5.1. С одного дерева сняли Х груш, а со второго 5 мальчиков, каждый из которых сидя на дереве, съел по 17 груш. После этого со второго дерева сняли еще Ү груш. Составитьпрограмму, которая определит, сколько груш было на обоих деревьях.Входные данные: 65 45Выходные данные: 195​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

gigbes
Alexander2035
ver2bit
Valerii276
egorova90356684858370
udalova-yelena
Dmitrii1763
Iiexota280274
ustinov434
Yeremeev
Aleksei1463
Arutyunovich
tsypant
Caragyant
sveta1308