srkushaev
?>

вообще не понимаю подобные задачи Напишите программу, которая считывает имена двух файлов. В первом файле записанномер координатной четверти, для которой нужно рассматривать точки, и максимальноерасстояние до подходящих точек. Во втором файле записаны координаты точекнаплоскости через пробел. Для указанной четверти выбрать точки, расстояние до которыхне превышает максимального, расположить ихв порядке убывания расстояния от началакоординат и записать кортежи ихкоординат в файл lucky. txt, каждый с новой строки.Если расстояния одинаковы, то в порядке ввода.Пример 1Вводfiles/coordinate_quarter.txtfiles/coordinates.txtВывод(-6.0, -1.0)(-4.0, -3.0)​

Информатика

Ответы

Светлана-Тигран
1. Если число в двоичной системе заканчивается на 00, значит оно кратно 4-м в десятичной системе. То есть нужно определить, сколько существует двузначных чисел, которые в квадрате кратны 4-м.10*10
Квадрат числа будет кратен четырем в том случае, если это число чётное, то есть ответом будет кол-во четных двузначных чисел, а это 45.

2. 3 бита это 2^3 = 1 из 8 вариантов. Значит четверки - это 1/8 от всех оценок, 64/8=8 четверок

3. Всего существует 5 четных цифр (включая 0). Из них можно составить 5^4 = 625 различных четырёхзначных комбинаций.
zbellatriks
#include <iostream>
using namespace std;
int main()
{ setlocale(0,"");
int a;
cout<<"введите значение погоды"<<endl;
cout<<"1-тепло"<<endl;
cout<<"2-жарко"<<endl;
cout<<"3-холодно"<<endl;
cout<<"4-колотун"<<endl;
cin>>a;
switch (a)
{
case 1: cout<<"вы можете одеть джинсы и футболку"<<endl; break;
case 2: cout<<"вы можете одеть шорты и майку "<<endl; break;
case 3: cout<<"вы можете одеть штаны и толстовку "<<endl; break;
case 4: cout<<"вы можете одеть куртку и свитер с подштанниками и ватными штанми "<<endl;
 break;
}
return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

вообще не понимаю подобные задачи Напишите программу, которая считывает имена двух файлов. В первом файле записанномер координатной четверти, для которой нужно рассматривать точки, и максимальноерасстояние до подходящих точек. Во втором файле записаны координаты точекнаплоскости через пробел. Для указанной четверти выбрать точки, расстояние до которыхне превышает максимального, расположить ихв порядке убывания расстояния от началакоординат и записать кортежи ихкоординат в файл lucky. txt, каждый с новой строки.Если расстояния одинаковы, то в порядке ввода.Пример 1Вводfiles/coordinate_quarter.txtfiles/coordinates.txtВывод(-6.0, -1.0)(-4.0, -3.0)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sokolowskayaa
Евгеньевич-Куликов1614
ooofishai4064
Евгений1286
guzelda19904850
Олег86
katrin50
voloshin238
ГазалиеваКозак
aaazovcev
stusha78938
Sadovskaya425
cutur3414
Kelena190533
makovei78