1. В простую переменную с клавиатуры последовательно ввести N чисел и посчитать их произведение. Написать программу на языке C++ 2. Вычислить сумму всех трехзначных чисел, произведение всех двузначных чисел. Написать программу на языке C++
var a: array[1..100] of real; i, n: integer; min, max: real; k: integer;
begin {ввод массива} if handsfree then n := random(20) + 5 else begin write('n = '); readln(n); end;
writeln('Данные массива:'); for i := 1 to n do begin if handsfree then begin a[i] := random(100); write(a[i], ' '); end else readln(a[i]); end; writeln();
{подсчет элементов} k := 0; for i := 1 to n do if a[i] > 5 then k := k + 1; writeln(k); end.
lenacari
02.11.2022
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016 begin var s:=ReadLnString('Вводите:'); s.ToWords.Where(x->x=ReverseString(x)).PrintLn; end.
Тестовое решение: Вводите: дед иван достал наган и пошел с ним в шалаш дед наган и с в шалаш
Вариант, если исключить однобуквенные:
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016 begin var s:=ReadLnString('Вводите:'); s.ToWords.Where(x->x=ReverseString(x)). Where(x->x.Length>1).PrintLn; end.
Тестовое решение: Вводите: дед иван достал наган и пошел с ним в шалаш дед наган шалаш
1) #include <iostream>
#include <vector>
using namespace std;
int main() {
vector<int> arr;
int N;
int sum = 0;
cin >> N;
for(int i = 0; i<N; ++i) {
int temp;
cin >> temp;
arr.push_back(temp);
if(i==0) {
sum = arr[i];
} else {
sum*=arr[i];
}
cout << "Sum: " << sum;
}
2) #include <iostream>
#include <vector>
using namespace std;
int main() {
vector<int> arr;
int N;
cin >> N;
int sum2(0), sum3(0);
for(int i = 0; i<N; ++i) {
int temp;
cin >> temp;
arr.push_back(temp);
if(arr[i]>9&&arr[i]<100) {
if(sum2==0) {
sum2=arr[i];
} else {
sum2*=arr[i];
}
} else {
if(arr[i]>99&&arr[i]<1000) {
sum3+=arr[i];
}
}
}
cout << "Sum2: " << sum2 << endl << "Sum3: " << sum3;
}