alfaduk24908
?>

Длинное целое Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input.txt Вывод стандартный вывод или output.txt Напишите программу, которая разные действия производит с разными числами. Формат ввода Вводится число. Формат вывода Если введено вещественное число, то вывести только его целую часть, а если целое – то количество разрядов. Ничего другого вводиться не будет. Пример 1 Ввод Вывод 2020.202 2020 Пример 2 Ввод Вывод 1234567890987654321 19 Примечания В задаче нельзя определять типы переменных.

Информатика

Ответы

Штакина1568

python

скорость выполнения зависит от мощности пк, а количество занимаемой памяти от длины ввода

inp = input()

if inp.find('.') != -1:

 print(inp.split('.')[0])

elif inp.find(',') != -1:

 print(inp.split(',')[0])

else:

 print(len(inp))

dbakun

import java.util.*;

import java.io.*;

public class Main {

static int _16yearsOld = 0;

       

static int min = 14;

      static int max = 16;

static int diff = max - min;

static Random random = new Random();

static int rand = random.nextInt(diff + 1);

rand += min;

   public static void main(string[] args) {

      int[] students = new int[19];

for (int i = 0; i <= students.size(); i++) {

students[i] = rand;

}

 

for (int i = 0; i <= students.size(); i++) {

if (students[i] == 16)  

    _16yearsOld++;

}

  }

}

Объяснение:

izumrud153

python

13)

for i in range(48):

 if i % 3 == 0:

   print(i)

 elif i % 2 == 0:

   print(i)

 elif i % 7 == 0:

   print(i)

 elif i % 3 == 2:

   print(i)

 elif i % 5 == 3:

   print(i)

14)

from math import floor

for i in range(30, 3000):

 if i / 5 == floor(i / 5) and i / 7 != floor(i / 7):

   print(i)

15)

amount = 0

new = 1000

day = 0

while amount < 30000:

 amount += new

 new *= 2

 day += 1

print(day)

16)

from math import floor

simple = True

number = int(input('Введите число: '))

for i in range(2, number):

 if number / i == floor(number / i):

   simple = False

   break

if simple:

 print('простое')

else:

 print('не простое')

17)

from math import floor

N = int(input('Введите N: '))

M = int(input('Введите M: '))

number = max(N, M)

while True:

 if number / N == floor(number / N) and number / M == floor(number / M):

   print(number)

   break

 else:

   number += 1

18)

from math import floor

for i in [int(i) for i in input('Введите  числа через пробел: ').split()]:

 if i / 4 == floor(i / 4) and i / 7 == floor(i / 7):

   print(i)

19)

number = int(input('Введите число: '))

if number**2 > 18:

 for i in range(number+1, number+11):

   print(i**2)

else:

 print(number)

20)

age = input('Введите возраст: ')

if age < 6:

 print('дошкольник')

 #я в школу пошел в 6 лет

elif 6 <= age < 18:

 print('школьник')

 #закончу школу в 17 лет

elif 18 <= age < 58:

 print('работник')

elif age >= 58:

 print('пенсионер')

 #у нас в Украине в 2017 году пенсионный возраст для женщин составляет 58 лет

#написал эти коментарии чтоб было понятно почему именно эти цифры

21)

from math import floor

number = int(input('Введите число: '))

for i in range(2, number):

 simple = True

 for z in range(2, i):

   if i / z == floor(i / z):

     simple = False

     break

 if simple:

   print(i)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Длинное целое Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input.txt Вывод стандартный вывод или output.txt Напишите программу, которая разные действия производит с разными числами. Формат ввода Вводится число. Формат вывода Если введено вещественное число, то вывести только его целую часть, а если целое – то количество разрядов. Ничего другого вводиться не будет. Пример 1 Ввод Вывод 2020.202 2020 Пример 2 Ввод Вывод 1234567890987654321 19 Примечания В задаче нельзя определять типы переменных.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ktripoleva294
houseoftorture138
fedoseevgleb
mez-omts-d5
Валерьевна1601
Vitalevich1187
vera2job7
samirmajbubi
Donat-Evgeniya793
Иванович-Васильевна1153
Курнев-Анастасия359
Anatolevich667
SEMENOV25352
igor-790
Smolkovaya