Пример на языке с++, дошел только для этого
#include<iostream>
using namespace std;
int min(int a, int b, int c, int d)
{
int min1 = 0;
int min2 = 0;
if (a < b)
{
min1 = a;
}
else
{
min1 = b;
}
if (c < d)
{
min2 = c;
}
else
{
min2 = d;
}
if (min1 < min2)
{
cout << "Наименьшее из чисел: " << min1 << endl;
}
else
{
cout << "Наименьшее из чисел: " << min2 << endl;
}
return 0;
}
int main()
{
setlocale(LC_ALL,"RUSSIAN");
min(10,20,30,40);
return 0;
}
Поделитесь своими знаниями, ответьте на вопрос:
1. Составить блок схему алгоритма и написать программу вычисления факториала, используя цикл do..while, с проверкой вводимого значения на ноль и на отрицательное значение. 2. Сделать описание программы. 3. Отчет оформить в документе WORD. Факториа́л — функция, определённая на множестве неотрицательных целых чисел. Название происходит от лат. factorialis — действующий, производящий, умножающий; обозначается n! Факториал натурального числа n определяется как произведение всех натуральных чисел от 1 до n включительно: n!=1*2*3*4* ….*n
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
int x, faktorial;
faktorial = 1;
cout << "vvedite x" << endl;
cin >> x;
if(x <= 0)
{
cout << "x dolgen bit' > 0" << endl;
return 0;
}
cout << "faktorial " << x " = "; //выводим заготовку для результата, так как x будет меняться
do
{
faktorial *= x; //faktorial = faktorial * x;
}
//если в условие цикла подставить число, то 0 преобразуется к "ложь", а ненулевое значение к "истина"
while(--x);//уменьшаем x на 1, затем проверяем его на 0
cout << faktorial << endl;
return 0;
}
Объяснение: