manu95957
?>

Написать программу! ) в эвм по очереди поступают результаты соревнований , в которых участвуют n спортсменов.составьте программу, которая обеспечивает вывод на экран лучшего результата каждыйраз после вводарезультата очередного спортсмена

Информатика

Ответы

Magnolia200872

var n,i: integer;

      result,thebest: real;

begin

  thebest: =1;

  writeln('введите количество спортсменов');

  readln(n);

  for i: =1 to n do begin

    writeln('введите результат ',i,' спортсмена');

    readln(result);

    if result> thebest then thebest: =result;

    writeln('лучший результат: ',thebest);

                          end;

end.

     

   

Viktor1316
Program fire; uses crt; var a,b,c,d,e,i,kol: integer; beginkol: =0; a: =15; b: =15; c: =15; d: =15; randomize; for i: =1 to 60 do    begin    e: =abs(random(5)-1);     if e=1 then a: =a-1;     if e=2 then b: =b-1;       if e=3 then c: =c-1;     if e=4 then d: =d-1;     if (a=0) or (b=0) or (c=0) or (d=0) then break;     kol: =kol+1;     end; writeln ('kolichestvo sgorevshih spichek= ',kol); end.
mirogall

//pascalabc v3.1

var s: string;

procedure repall(var s: string; wold, wnew: string);

var res: string;

    p, len: integer;

begin

  len: = length(wold);

  res: = '';

  while length(s) > 0 do begin

    p: = pos(wold, s);

    if p = 0 then begin res: = res + s; break; end;

    if p > 1 then res: = res + copy(s,1,p-1);

    res: = res + wnew;

    if p+len > length(s) then

          s: = ''

    else s: = copy(s,p+len,length(s));

  end;

  s: = res

end;

begin

  readln(s);

  repall(s, 'со', 'ту');

  writeln(s)

end.

тестовое решение:

сок сок сок кок пок

тук тук тук кок пок

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу! ) в эвм по очереди поступают результаты соревнований , в которых участвуют n спортсменов.составьте программу, которая обеспечивает вывод на экран лучшего результата каждыйраз после вводарезультата очередного спортсмена
Ваше имя (никнейм)*
Email*
Комментарий*