edelstar83
?>

с Питоном. Составить программу, позволяющую в одномерном массиве, состоящем из N случайно заданных элементов, вычисляющую указанное ниже значение. . Варианты вычисляемых значений: 1) сумма модулей отрицательных элементов массива; 2) количество положительных элементов массива; 3) количество элементов массива, не принадлежащих интервалу (a, b); 4) произведение элементов массива, меньших десяти

Информатика

Ответы

aobuhta4

как-то так

N = int(input('Кол-во элементов: '))

A = int(input('Начало интервала: '))

B = int(input('Конец интервала: '))

arr = [int(input()) for _ in range(N)]

sum_, countPos, countInt, comp = 0, 0, 0, 0

for i in arr:

 if i < 0:

   sum_ += abs(i)

 if i > 0:

   countPos += 1

 if i < A or i > B:

   countInt += 1

 if i < 10:

   if comp == 0:

     comp = i

   else:

     comp *= i

print(f'1. {sum_}\n2. {countPos}\n3. {countInt}\n4. {comp}')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с Питоном. Составить программу, позволяющую в одномерном массиве, состоящем из N случайно заданных элементов, вычисляющую указанное ниже значение. . Варианты вычисляемых значений: 1) сумма модулей отрицательных элементов массива; 2) количество положительных элементов массива; 3) количество элементов массива, не принадлежащих интервалу (a, b); 4) произведение элементов массива, меньших десяти
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yusliva
Сумарокова
gulyaizmailova
webotryvclub21
nikomuneskazhu60
dilbaryan76
Половников1964
tvtanya80
Alex-kustov
olqa27
natakrechko
Darialaza
Nikolaevich1534
Dmitrievna Lvovich
lovel24