Petrushin482
?>

с заданием Язык C# (C sharp) 1) написать программу, в которую пользователь вводит число. если число отрицательное( 0)-вычесть из числа 10. Если число равно нулю-вывести соответствующее сообщение. 2) С# написать программу в которую пользователь вводит 2 числа программа должна вычесть из большего меньшее и вывести его на экран 3) написать программу, в которую пользователь вводит свой рост вывести на экран выскоий если его рост больше или равен 180 и нормальный если рост меньше 180

Информатика

Ответы

MISAKOVNA49
Program Project1;

var m:array [0..14] of integer; i:integer;

function IsPositive(a:integer):boolean;
begin
  result:=(a>-1);
end;

procedure work;
var min, max, count:integer;
begin
  count:=0;
  min:=m[0];
  max:=0;
  for i:=0 to 14 do begin
    if IsPositive(m[i]) then begin
      inc(count);
      if m[i]>max then max:=m[i];
      if m[i]<min then min:=m[i];
    end;
  end;
  writeln('MAX: ', max);
  writeln('MIN: ', min);
  writeln('Count: ', count);
end;

begin
  for i:=0 to 14 do begin
    write('n: ');
    readln(m[i]);
  end;

  work;

  readln;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

с заданием Язык C# (C sharp) 1) написать программу, в которую пользователь вводит число. если число отрицательное( 0)-вычесть из числа 10. Если число равно нулю-вывести соответствующее сообщение. 2) С# написать программу в которую пользователь вводит 2 числа программа должна вычесть из большего меньшее и вывести его на экран 3) написать программу, в которую пользователь вводит свой рост вывести на экран выскоий если его рост больше или равен 180 и нормальный если рост меньше 180
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

shurshin6975
dima-pashkovec
Olga Arutyunyan
Мартынова_Ринатовна1657
Mikhail579
randat887040
i7aster26
laktionova-natal
Andreevich
Lomakina-Valerievna1779
Svetlana
oaved2018
zrs-546
mail2017
deputy810