germanleon
?>

написать программу в паскале. Вводятся координаты 5 различных (все координаты различны) точек на плоскости, через первые 3 проходит окружность (в частном случае прямая) через 2 оставшихся прямая. Вывести расстояние от окружности до прямой, если они не пересекаются и сообщение, что пересекаются в противном случае.

Информатика

Ответы

Ekaterina1654
Чтобы квадрат вписался в круг, его диагональ должна быть равна диаметру круга. Если трактовать "уместиться" как "пролезть", то диагональ должна быть меньше диаметра..
Формулы площадей квадрата  S₁ и круга S₂ известны, что легко позволяет нам найти нужное условие.
\displaystyle S_1=a^2 \to a=\sqrt{S_1}; \ d=a \sqrt{2}= \sqrt{2S_1} \\ S_2=\frac{\pi D^2}{4} \to D=\sqrt{\frac{4S_2}{\pi}}; \\ d\ \textless \ D \to \sqrt{2S_1}\ \textless \ \sqrt{\frac{4S_2}{\pi}}; \ 2S_1\ \textless \ \frac{4S_2}{\pi} \ \to \ \boxed{\pi s_1\ \textless \ 2S_2}
Если нужно, чтобы случай, когда квадрат вписан в круг тоже учитывался, строгое неравенство следует заменить нестрогим.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s1:=ReadReal('Площадь квадрата');
  var s2:=ReadReal('Площадь круга');
  if pi*s1<2*s2 then Writeln('Квадрат умещается в круге')
  else Writeln('Квадрат не умещается в круге')
end.

Тестовое решение:
Площадь квадрата 24.6
Площадь круга 28.4
Квадрат не умещается в круге

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу в паскале. Вводятся координаты 5 различных (все координаты различны) точек на плоскости, через первые 3 проходит окружность (в частном случае прямая) через 2 оставшихся прямая. Вывести расстояние от окружности до прямой, если они не пересекаются и сообщение, что пересекаются в противном случае.
Ваше имя (никнейм)*
Email*
Комментарий*