Leobed917670
?>

Кто знает паскаль Некоторая семья решила отдохнуть на море в июне месяце в течение 10-и дней. Они могут приобрести билеты только в первый день каждой декады месяца (т.е. 1-го июня, 11-го июня, 21-го июня Данные о прогнозе погоды в июне хранятся в текстовом файле vreme.in.Задача: Напишите программу, которая определяет декаду июня месяца с наибольшим количеством солнечных дней. Программа будет содержать подпрограмму с именем PS с целым параметром – начало декады июня (1, 11 или 21). Подпрограмма возвратит количество солнечных дней соответствующей декады.Ввод: Текстовый файл vreme.in содержит для каждого из 30-ти дней июня по одной букве, которая соответствует погоде соответствующего дня: ‘S’ – солнечно, ‘N’ - облачно, ‘P’ – дождь.Вывод: Текстовый файл vreme.out содержит две строки – в первой записаны два целых числа, разделенных дефисом – начало и конец периода отдыха. (Например: 1-10, 11-20 или 21-30), и во второй строке – количество солнечных дней в этом периоде. Примечание. Все три декады июня имеют разное количество солнечных дней.

Информатика

Ответы

sargisyan
1. Современное решение (быстро, просто и легко)
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('Ср.арифм: ',ReadSeqRealWhile(k->k>=0).Average:0:4)
end.

Пример
23 11.7 0 12.9 16.7 13 -12
Ср.арифм: 12.8833

2. Школьный вариант в стиле "1983г." (Turbo Pascal 7.0)

uses Crt;
var
  n:integer;
  x,a:real;
begin
  a:=0;
  n:=0;
  repeat
    Read(x);
    if x>=0 then begin
      n:=n+1;
      a:=a+x
      end
  until x<0;
  a:=a/n;
  Writeln('Ср.арифм: ',a:0:4);
  ReadKey
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Кто знает паскаль Некоторая семья решила отдохнуть на море в июне месяце в течение 10-и дней. Они могут приобрести билеты только в первый день каждой декады месяца (т.е. 1-го июня, 11-го июня, 21-го июня Данные о прогнозе погоды в июне хранятся в текстовом файле vreme.in.Задача: Напишите программу, которая определяет декаду июня месяца с наибольшим количеством солнечных дней. Программа будет содержать подпрограмму с именем PS с целым параметром – начало декады июня (1, 11 или 21). Подпрограмма возвратит количество солнечных дней соответствующей декады.Ввод: Текстовый файл vreme.in содержит для каждого из 30-ти дней июня по одной букве, которая соответствует погоде соответствующего дня: ‘S’ – солнечно, ‘N’ - облачно, ‘P’ – дождь.Вывод: Текстовый файл vreme.out содержит две строки – в первой записаны два целых числа, разделенных дефисом – начало и конец периода отдыха. (Например: 1-10, 11-20 или 21-30), и во второй строке – количество солнечных дней в этом периоде. Примечание. Все три декады июня имеют разное количество солнечных дней.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nataliatkachenko1
igor8809337
cafemgimo
svetkaiv
emilmishin1032
Fedorovich_Aleksandrovich685
masha812
yaelenatu
Сергеевич1396
ldstroy
Милита1065
helenavalenti2846
tsatskina857
zipylin
dimoni86