Нужно решить задачу (нужно решить на язике С++) Написать программу которая определяет является ли введенное число простым или нетввод: 2вывод: Yesввод: 5вывод: Yesввод: 179вывод: No
Объяснение: Создаем функцию которая ничего не возвращает, она принимает аргумент К. Это и есть число какое будем вводить. Создаем буллевую переменную. Делаем цикл с числа 2. Т.к 1, 2 простые. Смысла проверять нет. Если остатка от деления числа К на І не будет - значит оно не простое. Далее проверяем наш flag, main думаю понятно
P.S: Если не там Yes или No просто поменяй их текст
ответ:#include <iostream>
using namespace std;
void myFunc(int k) {
bool flag = true;
for(int i=2; i<k; i++)
{
if(k%i==0)
{
flag = false;
}
}
if(flag==true)
{
cout<<"Yes"<<endl;
}
else
{
cout<<"No"<<endl;
}
}
int main(int argc, char** argv) {
int a;
cout<<"Input a: ";
cin>>a;
myFunc(a);
return 0;
}
Объяснение: Создаем функцию которая ничего не возвращает, она принимает аргумент К. Это и есть число какое будем вводить. Создаем буллевую переменную. Делаем цикл с числа 2. Т.к 1, 2 простые. Смысла проверять нет. Если остатка от деления числа К на І не будет - значит оно не простое. Далее проверяем наш flag, main думаю понятно
P.S: Если не там Yes или No просто поменяй их текст