Алина Ракитин1730
?>

На с++ Напишите программу, которая строит матрицу смежности графа на основе списков смежности для каждой вершины. Входные данные В первой строке вводится количество вершин графа N ( 1 ≤ N ≤ 1000 В следующих N строках записаны списки смежности для каждой вершины – номера вершин, в которые существуют исходящие рёбра из данной вершины. Выходные данные Программа должна вывести матрицу смежности для заданного графа. Примеры входные данные 5 2 3 4 1 3 5 1 2 4 0 2 4 выходные данные 0 1 1 1 0 1 0 1 0 1 1 1 0 1 0 0 0 0 0 0 0 1 0 1 0

Информатика

Ответы

tkozina
Var
  arr : array [1..30] of integer;
  sum, count, i, a : integer;
begin
  read (a);
  for i := 1 to 30 do read (arr[i]);
  count := 0; sum := 0;
  for i := 1 to 30 do
  begin
    if arr[i] < 0 then sum := sum + arr[i]
    else if (arr[i] > 0) and (arr[i] <= a) then count := count + 1;
  end;
  writeln (sum, ' ', count);
end.

var
  arr : array [1..30] of integer;
  i : integer;
begin
  for i := 1 to 30 do read (arr[i]);
  for i := 30 downto 2 do
    if arr[i] * arr[i - 1] < 0 then // проверка знака
    begin
      writeln (i - 1); 
      halt; // Остановка программы
    end;
  writeln ('-1'); // Таких нет
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На с++ Напишите программу, которая строит матрицу смежности графа на основе списков смежности для каждой вершины. Входные данные В первой строке вводится количество вершин графа N ( 1 ≤ N ≤ 1000 В следующих N строках записаны списки смежности для каждой вершины – номера вершин, в которые существуют исходящие рёбра из данной вершины. Выходные данные Программа должна вывести матрицу смежности для заданного графа. Примеры входные данные 5 2 3 4 1 3 5 1 2 4 0 2 4 выходные данные 0 1 1 1 0 1 0 1 0 1 1 1 0 1 0 0 0 0 0 0 0 1 0 1 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kabinet17
hello
dimiff5
Жукова_Петрович1281
layna1241383
Panfilov_Anna
TSKaraulova
Anna_Kamil
kosharikclub
Alekseeva_Khlistov
Varvara
windless-el
ainetdinovsnab
Dmitrievna405
АнастасияAndrey
▲