larisau41
?>

Написать программу на языке Pascal Проверьте, верно ли, что количество строк матрицы A (n х n), в которой все числа нечетные, кратно заданному числу х.

Информатика

Ответы

alex6543213090

/*Решение с обобщения формула Брахмагупты для произвольного четырехугольника. Функция perimeter(double x[], double y[]) возвращает значение периметра, функция area(double x[], double y[]) возвращает значение площади, пример использования и реализация приведены ниже. */

#include <iostream>

#include <math.h>

double perimeter(double x[], double y[]);

double area(double x[], double y[]);

int main()

{

   double x[4], y[4];

   std::cout << "Quadrangle ABCD\n";

   for (auto i = 0; i < 4; i++)

   {

       std::cout << "Input coordinates of point " << char(i + 'A') << ": ";

       std::cin >> x[i] >> y[i];

   }

   std::cout << perimeter(x, y) << " " << area(x, y);

   

   return 0;

}

double perimeter(double x[], double y[])

{

   double a[4], p = 0;

   for (auto i = 0; i < 4; i++)

   {

       a[i] = sqrt((x[i]-x[(i + 1) % 4]) * (x[i]-x[(i + 1) % 4]) + (y[i]-y[(i + 1) % 4]) * (y[i]-y[(i + 1) % 4]));

       p += a[i];

   }

   return p;

}

double area(double x[], double y[])

{

   double a[4], p = 0, s = 1, d[2];

   for (auto i = 0; i < 4; i++)

   {

       a[i] = sqrt((x[i]-x[(i + 1) % 4]) * (x[i]-x[(i + 1) % 4]) + (y[i]-y[(i + 1) % 4]) * (y[i]-y[(i + 1) % 4]));

       p += a[i];

   }

   for (auto i = 0; i < 4; i++)

   {

       s *= (p / 2- a[i]);

   }

   for (auto i = 0; i < 2; i++)

   {

       d[i] = sqrt((x[i]-x[i + 2]) * (x[i]-x[i + 2]) + (y[i]-y[i + 2]) * (y[i]-y[i + 2]));

   }

   s -= (a[0] * a[2] + a[1] * a[3] + d[0] * d[1]) * (a[0] * a[2] + a[1] * a[3] - d[0] * d[1]) / 4;

   s = sqrt(s);

   return s;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке Pascal Проверьте, верно ли, что количество строк матрицы A (n х n), в которой все числа нечетные, кратно заданному числу х.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mila-vsv
Galiaahmatova4447
zerckaln
АнатольевичМиронова885
Расшифровать шифр эль-гамаля: 18 2 17 4 a=2 x=15 p=23
annayarikova
Сергеевич1386
mmctriitsk
Pavlovna897
jenek-f
natkoff5
marketing
besson89
akremlev2015
Dr-motoshop
ogofman