Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу, которая вычисляет и выводит значение функции =2−22−1 по заданному значению х, и выводит сообщение «не определена», если значение функции найти нельзя.
// delete.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include "iostream"#include <conio.h>
using namespace std;
int count_ = 0;
char m[6][6] = { {'S', '.', '.', '.', '#', '#'}, { '#', '.', '#', '.', '.', '.' }, { '.', '.', '#', '.', '.', '#' }, { '.', '.', '#', '#', '#', '.' }, { '#', '.', '.', '.', '#', '#' }, { '#', '#', '#', '.', '.', 'F' }};
int find_p(int x, int y) { if (x < 0 || x > 5 || y < 0 || y > 5) return 0; if (m[y][x] == 'F') return 1; if (m[y][x] != '.' && m[y][x] != 'S') return 0; m[y][x] = '+'; count_++; if (find_p(x, y - 1)) return 1; if (find_p(x + 1, y)) return 1; if (find_p(x, y + 1)) return 1; if (find_p(x - 1, y)) return 1; m[y][x] = 'x'; return 0;}
int main(){ find_p(0, 0); cout << count_; //вывод _getch(); // задержка return 0;}