Inozemtseva Korolev1271
?>

Дана матрица размера M на N (M - четное число Поменять местами верхнюю и нижнюю половину матрицы. Написать программу в С#

Информатика

Ответы

iivanovar-da

#include <iostream>

#include <vector>

using namespace std;

// глобальные переменные

const int arraySize = 10;

vector <int> numbers;

// сам алгоритм.

void result(){

   

 // совет - обьявляй все переменные в начале функции  

 int leader = 0;

 

 int maxCount = 0;

 int count = 0;

 

 

 // поиск самого частого числа

 for (int c = 0; c < 9;c++){

     // обнуляем счетчик

     count = 0;

     

     for (int c1 = 0;c1 < arraySize;c1++){

         if (numbers[c1] == c) count++;

     }

     

     // проверка на лидера

     if (maxCount < count){

         leader = c;

         maxCount = count;

     }

 }

 

 

 // ну..с посмотрим:

 cout << "Leader: " << leader << " (" << maxCount << ") " << std::endl;

}

int main()

{

   // подготовка масива

   srand(time(NULL)); // обнулем внутрений таймер для полного рандома

   for (int c = 0; c < arraySize;c++) {

       numbers.push_back(rand() % 9); // заполняем масив числами

   }

   // посмотрим на оригинальный масив

   cout << "Original array: ";

   for (int c = 0;c < arraySize;c++) cout << numbers[c] << " ";

   cout << std::endl;

   // сортировка

   result();

   return 0;

}

Объяснение:

Хорошая книга по с++: Герберт Шилд - с++ базовый курс.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана матрица размера M на N (M - четное число Поменять местами верхнюю и нижнюю половину матрицы. Написать программу в С#
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Илья_Ветклиники1655
zuelv
ustinovda14
kris5009646
yrgenson2011801
ev27076878
nevori
alekbur
Igorevich_Aleksandrovna1599
Nekrasova
sadinuraliev263
impuls20125948
Strelkov567
Dmitrychekov9
sidorov9
▲