vmnk38
?>

Дана правильная дробь a/b.Составить программу, сокращающую эту дробь (команда"повторять")​

Информатика

Ответы

Анатолий
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана правильная дробь a/b.Составить программу, сокращающую эту дробь (команда"повторять")​
Ваше имя (никнейм)*
Email*
Комментарий*