yugraspets
?>

PYTHON Написать программу и таблицу На PYTHON

Информатика

Ответы

sakalrip
Const n=15; 
var a:array[1..n] of integer;
i,s:integer; sr:real;
begin
Randomize;
writeln('Массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:3);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
sr:=s/n;
writeln('Среднее арифметическое = ',sr:6:2);
writeln('Номера элементов, больших среднего арифметического:');
for i:=1 to n do
 if a[i]>sr then write(i:3);
writeln;
end.

Пример:
Массив:
  9 19 14 8 7 10 5 10 6 14 15 2 11 17 13
Среднее арифметическое = 10.67
Номера элементов, больших среднего арифметического:
  2 3 10 11 13 14 15

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

PYTHON Написать программу и таблицу На PYTHON
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info6
Потапова 79275136869323
daryagulyaeva
margarita25061961
vifslafes
purchase
office426
dima0218687
Sergei
adminaa
mirsanm26249
dksvetlydir
annakuzina2023
dshi67orbru
Смирнов_Андрей691