Сергей_Комарова899
?>

1. Проанализируйте программу, представленную ниже. Какое число будет выведено на экран, если массив состоит из чисел [1, 2, 3, 4, 5]? const n = 5; var a: array [1..n] of integer; s, i: integer; begin s:=0; write('Введите элементы массива: '); for i:=1 to N do readln(a[i]); for i:=1 to N do s:=s+a[i]; writeln(s); end. 2. Напишите программу, выводящую на экран произведение всех элементов массива A(n Для написания программы подходит блокнот, имеющийся на любой версии ОС компьютера, или на языке программирования PascalABC.NET( )

Информатика

Ответы

Петренко1852

1) program Array16;

var

i:integer; // счетчик в цикле

N:integer;

a: array [1..10] of integer;

begin

writeln('Введите N (N<10)');

readln(N); // ввод размера массива

for i:=1 to N do

begin

write('a[',i,']=');

readln(A[i]); // ручной ввод значений массива

end;

writeln('Результат');

for i:=1 to N do

begin

// вычисление и вывод элементов в указанном порядке

write(' ',a[(i div 2+1)*((i) mod 2)+ n*((i+1)mod 2)-((i div 2)-1)*((i+1) mod 2)]);

end;

end.

2) Var A:array[1..100] of integer;

i,n:byte;

Begin

write('Введите n<=100: ');readln(n);

For i:=1 to n do

Begin

A[i]:=random(31);

write(A[i]:3);

End;

writeln;

For i:=1 to n div 2 do

write(A[i]:3,A[n-i+1]:3);

if n mod 2 <>0 then write(A[n div 2+1]:3);

End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. Проанализируйте программу, представленную ниже. Какое число будет выведено на экран, если массив состоит из чисел [1, 2, 3, 4, 5]? const n = 5; var a: array [1..n] of integer; s, i: integer; begin s:=0; write('Введите элементы массива: '); for i:=1 to N do readln(a[i]); for i:=1 to N do s:=s+a[i]; writeln(s); end. 2. Напишите программу, выводящую на экран произведение всех элементов массива A(n Для написания программы подходит блокнот, имеющийся на любой версии ОС компьютера, или на языке программирования PascalABC.NET( )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AMR89154331531
Александровна1244
milkline-nn
vera2job7
chavagorin
milanmilan8672
avdeevo
Екатерина15
nv6634
mbudilina
Yelizaveta1848
vasenkova1981
mariokhab
Алёна Геннадьевна98
taksa6444