okykovtun31
?>

Напишите программу(на Python), которая ищет среди целых чисел, принадлежащих числовому отрезку [130149; 130211], числа, имеющие ровно четыре различных натуральных делителя, не считая единицы и самого числа. Для каждого найденного числа запишите эти четыре делителя в ответ с новой строки в порядке убывания произведения этих четырёх делителей. Делители в строке должны следовать в порядке возрастания и быть записаны через пробел. Например, в диапазоне [10, 18] ровно четыре целых различных натуральных делителя имеют 12 и 18, поэтому для этого диапазона ответ: 2 3 6 9 2 3 4 6

Информатика

Ответы

annanechaeva567

#include <iostream>

void task1()

{

std::cout << "TASK_1\n";

for (int i = 1001; i <= 1025; i += 3)

 std::cout << i << " ";

std::cout << "\n\n";

}

void task2()

{

std::cout << "task_2\n";

unsigned n;

std::cout << "n: ";

std::cin >> n;

for (int i = 0; i < n; ++i)

 std::cout << "Silence is golden\n";

std::cout << "\n";

}

void task3()

{

std::cout << "task_3\n";

int sum = 0;

for (int i = 10; i <= 88; ++i)

 sum += i;

std::cout << sum << "\n\n";

}

void task4()

{

std::cout << "task_4\n";

for (int i = 100; i >= 1; i -= 4)

 std::cout << i << " ";

std::cout << "3 2 1\n\n";

}

int main()

{

task1();

task2();

task3();

task4();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу(на Python), которая ищет среди целых чисел, принадлежащих числовому отрезку [130149; 130211], числа, имеющие ровно четыре различных натуральных делителя, не считая единицы и самого числа. Для каждого найденного числа запишите эти четыре делителя в ответ с новой строки в порядке убывания произведения этих четырёх делителей. Делители в строке должны следовать в порядке возрастания и быть записаны через пробел. Например, в диапазоне [10, 18] ровно четыре целых различных натуральных делителя имеют 12 и 18, поэтому для этого диапазона ответ: 2 3 6 9 2 3 4 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

valentinakarma2800
KIRILLSHURYGIN98
purchase
olesyashazk5055
Евгений1286
denis302007
elenachuxina804
margo929
cheshirsky-kot
docvet4
yurievaalxndra55
Dmitrii1763
A2017
e90969692976
Есартия52