1)
var
a,i,count:integer;
begin
readln(a);
count:=0;
for i:=1 to a do
if a mod 13 = 0 then
inc(count);
end;
writeln('Count: ',count);
end.
2)
a,i,max:integer;
repeat
if a>100 then
writeln('Error.Repeat');
until a<=100;
if i = 1 then
max:=a
else
if max < a then
max:=a;
writeln('Max: ',max);
Поделитесь своими знаниями, ответьте на вопрос:
В классе 20 учеников писали диктант по русскому языку. Напишите программу, подсчитывающую количество двоек, троек, четвёрок и пятёрок, полученных за диктант на языке c++
1)
var
a,i,count:integer;
begin
readln(a);
count:=0;
for i:=1 to a do
begin
readln(a);
if a mod 13 = 0 then
inc(count);
end;
writeln('Count: ',count);
end.
2)
var
a,i,max:integer;
begin
readln(a);
for i:=1 to a do
begin
repeat
readln(a);
if a>100 then
writeln('Error.Repeat');
until a<=100;
if i = 1 then
max:=a
else
if max < a then
max:=a;
end;
writeln('Max: ',max);
end.