см. объяснения + скрин
Объяснение:
program prog;
var
num,chetnoe,nechetnoe,ost :integer;
begin
writeln('Vvedite chislo:');
readln(num);
chetnoe:=0;
nechetnoe:=0;
if num=0 then chetnoe:=1 else
while (num<>0) do begin
ost:=(num mod 10) mod 2;
if (ost=0) then chetnoe:=chetnoe+1
else nechetnoe:=nechetnoe+1;
num:=num div 10;
end;
writeln('четныx = ',chetnoe);
writeln('нечетных = ',nechetnoe);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу , определяющую в каком из данных двух чисел больше четных цифр язык программирования Pascal)
см. объяснения + скрин
Объяснение:
program prog;
var
num,chetnoe,nechetnoe,ost :integer;
begin
writeln('Vvedite chislo:');
readln(num);
chetnoe:=0;
nechetnoe:=0;
if num=0 then chetnoe:=1 else
begin
while (num<>0) do begin
ost:=(num mod 10) mod 2;
if (ost=0) then chetnoe:=chetnoe+1
else nechetnoe:=nechetnoe+1;
num:=num div 10;
end;
end;
writeln('четныx = ',chetnoe);
writeln('нечетных = ',nechetnoe);
end.