ccc712835
?>

Составить программу и вычислить по три значения функции у1, у2, у3. Вычисление суммы, произведения, факториала

Информатика

Ответы

levsha-27509

Программа:

Python:

import sys

max, min = -(sys.maxsize), sys.maxsize

c = 0

N = int(input('N = '))

print('Введите массив:')

arr = [int(input()) for i in range(N)]

for i in arr:

   if len(str(i)) == 2 and i % 3 == 0:

       if i < min:  min = i

       elif i > max:  max = i

if max != -(sys.maxsize):  print('Максимальное число:', max)

else: print('Нет максимального числа')

if min != (sys.maxsize):  print('Минимальное число:', min)

else: print('Нет минимального числа')

Pascal:

var

 arr: array of integer;

 N, i, max, min, j, c: integer;

procedure Symv(j: integer; var c: integer);

begin

 while j > 0 do begin

   j := j div 10;

   c += 1;

 end;

end;

begin

 max := -MAXINT;

 min := MAXINT;

 write('N = ');  readln(N);

 SetLength(arr, N);

 writeln('Введите элементы массива:');

 for i := 0 to N - 1 do readln(arr[i]);

 writeln(arr);

 

 for i := 0 to N - 1 do begin

   Symv(arr[i], c);

   if (c = 2) and (arr[i] mod 3 = 0) then begin

     if arr[i] < min then min := arr[i]

     else if arr[i] > max then max := arr[i]

   end;

   c := 0;

 end;

 

 if max <> -MAXINT then writeln('Максимальное число: ', max)

 else writeln('Нет максимального числа.');

 if min <> MAXINT then writeln('Минимальное число: ', min)

 else writeln('Нет минимального числа.');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу и вычислить по три значения функции у1, у2, у3. Вычисление суммы, произведения, факториала
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dshi67orbru
Evelina Mariya
dianakryukova00
tsypant
antoska391
yuip2008
sergeyshuvalov
AndrukhovichKonovalov
Aleksei806
sabinina0578
pizniak
сергей1246
николаевич-Елена988
gurman171
iivanov54