?>
Условие Дано натуральное число. Определите, сколько раз в нем встречается минимальная цифра. Формат входных данных В программу вводится одно целое число x (1≤x≤231−1 Формат выходных данных Программа должна вывести количество минимальных цифр в этом числе. входные данные 1000 1234321 выходные данные 3 2
Ответы
#include <iostream>
#include <vector>
#include <algorithm>
int main() {
unsigned num;
std::vector<unsigned> nums;
std::cout << "Input num: ";
std::cin >> num;
while(num != 0){
nums.push_back(num % 10);
num /= 10;
}
std::sort(nums.begin(), nums.end());
std::cout << "Minimum digit amount: " <<
std::count(nums.begin(), nums.end(), nums[0])
<< std::endl;
return 0;
}