Відповідь:
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL , "Rus");
int a,b,x,y;
cout << "Введите первое число: ";
cin >> a;
cout << "Введите второе число: ";
cin >> b;
if(a % b == 0){
cout << "Делится" << endl;
x = a / b;
cout << "Частное: " << x << endl;
}
else if(a % b != 0){
cout << "Не делится" << endl;
y = a % b;
cout << "Частное: " << x << " Остаток: " << y << endl;
return 0;
Поделитесь своими знаниями, ответьте на вопрос:
нужно написать программу поиска максимального четного числа из 100 случайных чисел, созданных генератором случайных чисел. А в программе использовать структуру ветвление и цикл с фиксированным количеством повторов.
Відповідь:
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL , "Rus");
int a,b,x,y;
cout << "Введите первое число: ";
cin >> a;
cout << "Введите второе число: ";
cin >> b;
if(a % b == 0){
cout << "Делится" << endl;
x = a / b;
cout << "Частное: " << x << endl;
}
else if(a % b != 0){
cout << "Не делится" << endl;
x = a / b;
y = a % b;
cout << "Частное: " << x << " Остаток: " << y << endl;
}
return 0;
}