?>
Задача 2. Составьте программу, которая определяет сколько нужно заплатить за электроэнергию, если потребитель использовал в этом месяце N кВт/ч, астоимость 1 кВт/ч составляет 17, 79 тг. Составьте программу.Входные данные: NВыходные данные (результат): cost
Ответы
pascal
Объяснение:
const K = 8;
var
b : array [0..K - 1] of integer;
x, y, z, count : integer;
begin
for x := 0 to K - 1 do
readln(b[x]);
for x := 0 to K - 2 do
for y := x + 1 to K - 1 do
if b[x] > b[y] then
begin
z := b[x];
b[x] := b[y];
b[y] := z;
end;
z := 1;
write(b[0], ', ');
for x := 1 to K - 1 do
if b[x] <> b[x - 1] then
begin
write(b[x], ', ');
inc(z);
end;
writeln();
writeln('Кол-во уникальных элементов : ', z);
end.