Verakravez8790
?>

Сор по информатике 6 класс 1. Назовите 3 элемента из которых состот алфавит языкапрограммирования Python [3]b)c) , 2. Что такое переменная?3. Какие действия выполняют данные знакиа) хуb) x % у4. Определите типы данных:a) Intob) Floato)5. Опредемте результат выполнения программыb = 6otvel = a + b cprint/otvet)​

Информатика

Ответы

Хохлов
В принципе, можно расписать, что делает эта программа (см. вложение). Так как изначально a[6] = 0, то a[3] = 50 раз к a[5] прибавится 2 * a[4] = 38, получится 38 * 50 + a[5] = 1917, затем значение a[5] будет выведено на экран.

Но проще не мучиться и просто написать программу, выполняющую этот код.

python 3.
array = [10, 330, 50, 19, 17, 0, 184, 0]
array_position = 2
program = "[->[->+>+<<]>>[-<+<+>>]<<<]>>."

stack = []
transitions = [None] * len(program)
for k, op in enumerate(program):
    if op == '[':
        stack.append(k)
    elif op == ']':
        v = stack.pop()
        transitions[k] = v + 1
        transitions[v] = k + 1
 
k = 0
while k < len(program):
    op = program[k]
    if op == '.':
        print(array[array_position])
    elif op == '>':
        array_position += 1
    elif op == '<':
        array_position -= 1
    elif op == '[' and array[array_position] == 0:
        k = transitions[k]
        continue
    elif op == ']' and array[array_position] != 0:
        k = transitions[k]
        continue
    elif op == '+':
        array[array_position] += 1
    elif op == '-':
        array[array_position] -= 1
    k += 1
Петя и вася придумали язык программирования мозг. в нём используются 8 ячеек памяти, и есть следую

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сор по информатике 6 класс 1. Назовите 3 элемента из которых состот алфавит языкапрограммирования Python [3]b)c) , 2. Что такое переменная?3. Какие действия выполняют данные знакиа) хуb) x % у4. Определите типы данных:a) Intob) Floato)5. Опредемте результат выполнения программыb = 6otvel = a + b cprint/otvet)​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Шабунина-Евгения1883
Veronika343
snopok66
office46
Татьяна-Мария
rabchek145200614
Сорокина-Светлана
Евгеньевна_Хусинов
eremenkou
Koranna1986
Стяжкин
Tarapovskaya
miumiumeaow
Grishanin
zaschitin48