sergeyshuvalov
?>

Напишите программу на Паскале для решения следующей задачи. Даны два числа A и B, которые не равны друг другу. Большее из этих чисел нужно заменить половиной разности этих двух чисел, а меньшее — их удвоенным произведением. Значения A и B задать самостоятельно с клавиатуры. На проверку нужно прислать скриншот окна программы на Паскале с результатом работы​

Информатика

Ответы

katcoffe3
#include <iostream>
#include <cstdlib>
#include <ctime>
int main()
{
    using namespace std;
    cout << "Enter size of array: ";
    int N;
    cin >> N;
    int * ARR = new int[N];
    srand(time(0));
    int i;
    for (i = 0; i < N; ++i)
        ARR[i] = rand() % 100 + 1;

    cout << "Here is an original array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    int temp = ARR[N - 1];
    for (i = N - 1; i > 0; --i)
        ARR[i] = ARR[i - 1];
    ARR[0] = temp;

    cout << "\nHere is a new array:\n";
    for (i = 0; i < N; ++i)
        cout << ARR[i] << "  ";
    cout << endl;

    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на Паскале для решения следующей задачи. Даны два числа A и B, которые не равны друг другу. Большее из этих чисел нужно заменить половиной разности этих двух чисел, а меньшее — их удвоенным произведением. Значения A и B задать самостоятельно с клавиатуры. На проверку нужно прислать скриншот окна программы на Паскале с результатом работы​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Виктория Нина
qcrv15312
pavelriga5
motor2218
Олег86
Kosov-Aleksandr379
lihacheva
Дмитриевич Бирковская69
Виталий887
yuliyastatsenko3894
ielienakozlova696
dianabuchkina
Lorvi_Shevkunova849
Chopper-hinter25
filantropagv4
▲