?>
Укажите имена переменных, значения которых будет необходимо ВВЕСТИ В программу при ее выполнении:У Царевны-лягушки собралось і любовных посланий, из них х посланий набумаге, у посланий на бересте, а остальные на стрелах. Составьте программу, находящую, сколько посланий на стрелах собрала Царевна-лягушка.ПуZаb
Ответы
function nmbdec(var n,osn: integer): integer;
var nmb,l,s,k: integer;
begin
nmb:=0; s:=0;
k:=n; l:=1;
while k>0 do
begin
s:=k mod 10;
k:=k div 10;
nmb:=nmb+l*s;
l:=l*osn;
end;
Result:=nmb;
end;
{ конец функции}
begin
write('число: ');
readln(n);
write('квадрат какого числа: ');
readln(m);
osn:=10;
while osn>=2 do
begin
osn:=osn-1;
if nmbdec(n,osn)=sqr(nmbdec(m,osn)) then
begin
writeln('основание системы = ',osn);
break;
end;
end;
end.