Irina_Nikolai
?>

Составьте программу нахождения наибольшего общего делителя трех чисел используя следующую формулу Нод (А, В, С) =Нод (Нод(А, В, С)

Информатика

Ответы

annasolod
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (m,n):=ReadInteger2('Количество строк и столбцов в массиве:');
  Writeln('*** Исходный массив ***');
  var d:=MatrRandom(m,n,-99,99);
  d.Println(4); Writeln(4*d.ColCount*'-');
  var min:=d.ElementsByRow.Min; // значение минимального элемента
  Writeln('Искомое среднее: ',d.ElementsByRow.Where(t->t<>min).Average)
end.

Пример
Количество строк и столбцов в массиве: 4 7
*** Исходный массив ***
   7 -31  80  21  38 -36  16
  42  93 -11  74  -6  37 -71
  15  90 -71 -88 -71  70 -27
  12  83  41  79  72  91 -88

Искомое среднее: 24.5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу нахождения наибольшего общего делителя трех чисел используя следующую формулу Нод (А, В, С) =Нод (Нод(А, В, С)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

verakmves
boldyrevanastia22
vkaloshin
Бочкова_Елена203
milkiev
homeo85
gaina6678
valerii_Georgievna915
nikiforovako76
Николаевич-Анатольевич599
Fateevsa9
Galina_Yurevna
des-32463
mvolkov8
moisalexx7