Lorvi_Shevkunova849
?>

1. написать программу, которая в заданном с клавиатуры массиве из 7 целых чисел находит сумму элементов, меньших 4. 2. написать программу, которая находит произведение элементов массива натуральных чисел из 15 элементов, заданного случайным образом. 3. написать программу, которая определяет, находится ли в заданном случайным образом массиве из n натуральных чисел заданное число m (m вводятся с клавиатуры, n -константа

Информатика

Ответы

hacker-xx1
//fromstudent //без строк var n, nn: longint; i : byte; function pow (p: longint; k: byte): longint; var j : byte; sum : longint; begin sum: =1; if k> 0 then for j: =1 to k do sum: =sum*p; pow: =sum; end; begin write ('введите число: '); readln (n); while n> 0 do begin     if (n mod 10)< > 1 then     begin     inc (nn, pow (10, i)*(n mod 10));     inc (i);     end; n: =n div 10; end; write ('полученное число: ', nn); end.
cosmetic89

надеюсь правильно!!!!

Объяснение:

Определим количество зрителей (мест):

35*40 = 1400

То есть нужно определить количество бит, которое требуется для кодирования 1400 номеров.

Для кодирования 1400 номеров требуется как минимум 11 бит. Разберемся, почему так:

С десяти бит мы можем закодировать максимум 1024 номера, т.к. 2^10 = 1024 (степень двойки - это количество бит). То есть десяти бит явно не достаточно для кодирования 1400 номеров.

Зато с одиннадцати бит мы можем закодировать 2^11=2048 номеров, и этого достаточно для кодирования 1400 номеров.

Один номер занимает 11 бит, объем 216 номеров равен:

216*11 = 2376 бит

ответ: 2376 бит.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. написать программу, которая в заданном с клавиатуры массиве из 7 целых чисел находит сумму элементов, меньших 4. 2. написать программу, которая находит произведение элементов массива натуральных чисел из 15 элементов, заданного случайным образом. 3. написать программу, которая определяет, находится ли в заданном случайным образом массиве из n натуральных чисел заданное число m (m вводятся с клавиатуры, n -константа
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

slitex
julya847
АркадьевичБундин789
djikia88
golovins3
megapolisgroup
Михайлов
utkinslava
k-alexey9
mskatrinmadness
VASILEVNA
Khlistova1488
potap-ver20065158
Zeegofer
goldenshtein33333