Хохлова Иванович
?>

Составьте программу, в которой значение переменной с вычисляется по формуле: а + ь, если а — нечетное (a mod 2 = 1), и а*ь, если а — четное (а mod 2 = 0)

Информатика

Ответы

Svatela37

var

a,b,s: integer;

begin

readln (a,b);

if (a mod 2 = 1)

then s : = a + b

else if (a mod 2 = 0)

then s : = a * b;

write(s);

end.

Viktoriya

Во Определите какие имена переменных записаны по правилам допустимым в Паскале.

Варианты ответов

swD2

2yD2

_tt8

5R_67

Y_5

Во Кто разработал язык программирования Паскаль?

Варианты ответов

Блез Паскаль

Никлаус Вирт

Чарльз Беббидж

Джон фон Нейман

Норберт Винер

Во Какое служебное слово в языке программирования Паскаль используется для описания целого типа?

Варианты ответов

real

integer

string

Во Определите какие операторы присваивания записаны верно (учитывая структуру оператора, имена переменных и синтаксис записи выражения).

Варианты ответов

a := 5;

a := 5, 7;

7b := x + y;

y := 5 + 4x;

a10 := 5 + b;

Во Определите какой из операторов определяет вывод значения переменной и переход на новую строку

Варианты ответов

read

readln

write

writeln

legezin

1)Язык программирования Pascal создал:

1.Н. Вирт

2.Б. Паскаль

3.М. Фортран

2) Линейная структура построения программы подразумевает

1.Неоднократное повторение отдельных частей программы

2.Последовательное выполнение всех элементов прЛинейная структура построения программы подразумевает

3.Выполнение лишь нескольких, удовлетворяющих заданному условию частей программы

3) Команда CLRSCR служит для

1.ожидания нажатия клавиши

2.ввода данных с экрана

3.очистки экрана

4) раздел VAR служит

1.Для описания используемых переменных

2.Для описания величин

3.Для описания выражений

5)Переменные – это:

1.величины, которые могут менять свое значение в процессе выполнения программы

2.величины, которые не могут менять своего значения в процессе выполнения программы

3.обозначают строки программы, на которые передается управление во время выполнение программы

6) целочисленное деление можно выразить следующей функцией:

1.A mod B

2.A div B

3.Abs (A)*B

7) раздел операторов начинается служебным словом:

1.VAR

2.INTEGER

3.BEGIN

8) ввод данных с клавиатуры осуществляется с оператора:

1.WRITE, WRITELN

2.READ, READLN

3.PROGRAM

9)вывод данных на экран осуществляется с оператора:

1.WRITE, WRITELN

2.READ, READLN

3.PROGRAM

10) тип переменных REAL это:

1.целочисленный тип

2.логический тип

3.натуральный тип

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, в которой значение переменной с вычисляется по формуле: а + ь, если а — нечетное (a mod 2 = 1), и а*ь, если а — четное (а mod 2 = 0)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

merx80
chuykin
olg14855767
elenalukanova
Aksinya1036
Strelkov-Roman1263
Savva1779
Zelinskaya-Andrei
mac4roc3781
Aleksei
goodsled
Александра Викторович531
oalexandrova75
potapin
terehin863