billl24
?>

1составить программу при поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . в массиве a[n] записаны оценки экзаменующихся , полученные на первом экзамене . подсчитать , сколько человек не допущено ко второму экзамену . 2 в одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) минимальный элемент массива; 2)сумму элементов массива , расположенных между первым и последним положительными элементами . преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .

Информатика

Ответы

Агибалов428

массив определи как array[];

чтобы посчитать, просто используй счетчик, но сначала инициализируй переменную, которая содержит ответ :

int n;

array [n];

int answer;

for (i=0, i < n, i++)

{

      if (array[i] == 2)

          answer++;

std: : cout< < answer;

как то так

 

 

 

array[n];

 

 

for (int i =1, i < n, i++)

{

  if (array[0] > = array[i])

    array[0] = array[i];

}

std: : cout < < array[0];

//это было решение первого пункта

int first;

int last

bool positive;

while (positive == false )

{

    for (int i = 0; i < n; i++)

      {

        if (array[i] > 0)

        {

          positive = true;

          first = i;

          array[i] = -1;

      }

}

while (positive == false )

{

    for (int i = 0, i < n, i++)

      {

        if (array[i] > 0)

        {

          positive = true;

          last = i;

      }

}

 

 

int summ

for (int i = first, i < last, i++)

{

  summ += array[i];

}

  std: : cout< < summ; // ответ на 2 пункт

// преобразую

newarray [n];

int a = 0;

for (int i = 0, i < n, i++)

{      

  if (array[i] == 0)  

    {      

newarray[a] = array[i];      

  a++;      

    }  

for (int i = 0, i < n, i++)

{    

      if (array[i] ! = 0)    

          {        

          newarray[a] = array[i];

          a++;

        }

}

std: : cout< < newarray;

vorobyeva6428
Program maas; const n=12; var   a: array[1..n] of integer;   i, sum, sumn: integer;   begin   write('массив: ');     for i : = 1 to n do     begin       a[i] : = random(10);     write(a[i], ' ');       if i mod 2 = 0 then inc(sum, a[i])     else inc(sumn, a[i]);     end;   writeln;     writeln('сумма элементов с четными индексами = ', sum);   writeln('сумма элементов с нечетными индексами = ',sumn); end.
nadyatsoi
Вот код программы, я думаю в  нём алгоритм видно? )   int a; int b;             console.writeline("введите первое число");       a = int.parse( console.;           ///1)вводим первое число   console.writeline("введите второе число");       b = int.parse(console.;           ///2) вводим второе число   if (a < b) console.writeline("меньше а = " + a);       ///3)сравниваем, если а< b пишем а if (a > b) console.writeline("меньше b = " + b);     ///4)сравниваем, если а> b пишем b if (a == b) console.writeline("а = b = " + a);           ///3)сравниваем, если а=b пишем а             console.readline();

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1составить программу при поступлении в вуз абитуриенты , получившие "двойку" на первом экзамене , ко второму не допускаются . в массиве a[n] записаны оценки экзаменующихся , полученные на первом экзамене . подсчитать , сколько человек не допущено ко второму экзамену . 2 в одномерном массиве , состоящем из n вещественных элементов , вычислить ; 1) минимальный элемент массива; 2)сумму элементов массива , расположенных между первым и последним положительными элементами . преобразовать массив таким образом , чтобы сначала располагать все элементы , равные нулю, а потом-все остальные .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Бернард pokerman
vladimirkirv
kun1969
menesmir
dmitriy
verkop9
klimovala2
Максим_Нина
andreu420082132
Vyacheslavovich-Gubanov
muzeynizhn
Vello Olga
andyrvo
АнжелаВасильевич
YuREVICh646