ГармаеваЕкатерина1637
?>

Прошу если можно, сразу вид, как в паскале билет по икт составить программу, определяющую большее из двух чисел. проверить работу программы для всевозможных комбинаций

Информатика

Ответы

neganovaarxi

program arika2; uses crt; var  a,b: integer; begin  writeln('*** alphaues is ***');   writeln('***                  ok                        ***');   writeln();   writeln('введите два числа');   write('первое: '); readln(a);   write('второе: '); readln(b);   if a> b then          writeln('первое число больше второго')      else          if a> b then                  writeln('второое число больше первого')              else                  writeln('числа равны'); end.

macmakka

program proga;  

uses crt;

var

  x,y: integer;

begin

clrscr;  

writeln('введите поочередно два числа');

readln(x);

readln(y);  

if x> y then

writeln(' x> y ')

else

if y> x then

writeln(' y> x ') 

else

  writeln(' y=x ')   ;

writeln;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

klimenokvapeshop1408

program n_2;

var i: integer;

   a: array[1..10] of integer;

begin

 randomize;

 for i:=1 to 10 do

   a[i]:=random(100);

 for i:=1 to 10 do

   write(a[i],' ');

end.

Вычисление суммы элементов массива

program  n_3;

 var s, i: integer;

     a: array[1..10] of integer;

begin  

 s:=0;

 randomize;

 for i:=1 to 10 do a[i]:=random(100);

 for i:=1 to 10 do write (a[i],' ');

 for i:=1 to 10 do s:=s+a[i];

 writeln('s=', s)

end.

Вычисление суммы элементов массива

[Используем операторные скобки и всё (ввод, вывод, обработку) делаем в одном цикле]

program  n_3_1;

 var s, i: integer;

     a: array[1..10] of integer;

begin  

 s:=0;

 randomize;

 for i:=1 to 10 do

    begin  

       a[i]:=random(100);

       write(a[i],' ');

       s:=s+a[i]

    end;

 writeln('s=', s)

end.

Программа поиска наибольшего элемента в массиве

program  n_4;

 var i, imax: integer;  

     a: array[1..10] of integer;

begin  

 randomize;

 for i:=1 to 10 do a[i]:=random(100);

 for i:=1 to 10 do write(a[i],' ');

 imax:=1;

 for i:=2 to 10 do

   if a[i]>a[imax] then

      imax:=i;

 write('Наибольший элемент   a[', imax, ']=', a[imax])

end.

Поиск элемента, равного 50

program  n_5;

var   n, i: integer;  

     a: array[1..10] of integer;

begin  

 randomize;

 for i:=1 to 10 do a[i]:=random(100);

 for i:=1 to 10 do write(a[i],' ');

 n:=0;

 for i:=1 to 10 do

   if a[i]=50 then

      n:=i;

 if n=0 then

    write('Нет')

 else

    write(n)

end.

Поиск элемента, равного 50

program  n_5_1;

 var n, i: integer;  

     a: array[1..10] of integer;

begin  

 randomize;

 for i:=1 to 10 do a[i]:=random(100);

 for i:=1 to 10 do write(a[i],' ');

 i:=0;

 repeat

   i:=i+1;

 until (a[i]=50) or (i=10);

 if a[i]=50 then

   write(i)  

 else  

   write('Нет')

end.

Для подсчета вводится переменная, значение которой увеличивается на единицу каждый раз, когда найден нужный элемент.

program  kolich;

var   k, i: integer;  

     a: array[1..10] of integer;

begin  

 randomize;

 for i:=1 to 10 do a[i]:=random(100);

 for i:=1 to 10 do write (a[i],` `);

 k:=0;

 for i:=1 to 10 do

   if a[i]>50 then

      k:=k+1;

 write('k=', k)

end.

Сумма значений элементов, удовлетворяющих условию

program  sum ;

var   s, i: integer;  

     a: array[1..10] of integer;

begin  

 randomize;

 for i:=1 to 10 do

   a[i]:=random(100);

 for i:=1 to 10 do

   write (a[i],` `);

 s:=0;

 for i:=1 to 10 do

   if (a[i]>10) and (a[i]<30) then

     s:=s+a[i];

 write('s=', s)

end.

Сортировка массива

program sort;

var   n, i, j, x, imax: integer;

     a: array [1..10] of integer;

begin

 for i:=1 to 10 do read (a[i]);

 for i:=1 to 10 do write (a[i], ' ');

 for i:=1 to 9 do

 begin

   imax:=i;

   for j:=i+1 to 10 do

     if a[j]>a[imax] then

       imax:=j;

   x:=a[i];

   a[i]:=a[imax];

   a[imax]:=x

 end;

 for i:=1 to 10 do

   write(a[i], ' ')

end.

Возведение числа в любую степень.

program calc_stepen;

var

 a, b, h, i: integer;

 c: real;

begin

 b := 1;

 readln( a, h);

 for i := 1 to abs(h) do

   b := b * a;

 if h < 0 then

   c := 1 / b

 else

   c := b;

 writeln( c:3:5 );

end.

Определение гласных и согласных букв:

program alfabet;

var

 s: char;

begin

 read(s);

 case s of  

   'а','е','ё','и','о','у','ы','э','ю','я': writeln('гласные');

   'б','в','г','д','ж','з','й','к','л','м','н','п','р','с','т','ф','х','ц','ч','ш','щ': writeln('согласные');

   

 else

   writeln('знаки');

 end;

end.

Объяснение:

propercarwashes275
// pascalabc.net 3.2, сборка 1382 от 06.02.2017 // внимание! если программа не работает, обновите версию! begin   var n: =readinteger('количество строк в массиве: ');   var m: =readinteger('количество столбцов в массиве: ');   writeln('*** исходный массив [',n,',',m,'] ***');   var a: =matrrandom(n,m,-99,99);   a.println(4); writeln(5*a.colcount*'-');   a.cols.select(x-> format('{0,4}',x.where(y-> y> 0).('');   println(' - положительных');   a.cols.select(x-> format('{0,4}',x.where(y-> y< 0).('');   println(' - отрицательных'); end. пример количество строк в массиве: 5 количество столбцов в массиве: 8 *** исходный массив [5,8] ***   32  83 -68 -33 -63  43    0  30   81  46 -52  56  49  10 -31    9   -41 -56 -80  70 -95  94 -53  56     0 -87 -24  23 -54  24 -84  -3   22  74  54 -98  42  94 -68  59     3    3    1    3    2    5    0    4 - положительных     1    2    4    2    3    0    4    1 - отрицательных

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прошу если можно, сразу вид, как в паскале билет по икт составить программу, определяющую большее из двух чисел. проверить работу программы для всевозможных комбинаций
Ваше имя (никнейм)*
Email*
Комментарий*