Витальевна
?>

Написать программу, которая проверяет, является ли введенная с клавиатуры строка целым числом

Информатика

Ответы

edvlwork15
Var       s: string;       i: longint; begin       read(s);       for i : = 1 to length(s) do              if not((ord(s[i]) > 47)and(ord(s[i]) < 58)) then begin             write(s,' - не является целым число'); exit;         end;       write(s,' - целое число');   end.
yelenaSmiryagin
1) program cgt; var a: array[1..100,1..100]of integer; s,n,m,i,j: integer; begin read(n,m); s: =0; for i: =1 to n do for j: =1 to m do read(a[i,j]); for i: =1 to n do begin for j: =1 to m do if(i mod 2=1)then s: =s+a[i,j]; end; writeln(s); end.2)program cgt; var a: array[1..100,1..100]of integer; n,m,i,j: integer; s,p: real; beginread(n,m); s: =0; for i: =1 to n dofor j: =1 to m doread(a[i,j]); for i: =1 to n dobeginp: =1; if(i mod 2=0)then beginfor j: =1 to m dobeginp: =p*(sin(a[i,j]*pi/180))/(cos(a[i,j]*pi/180)); end; s: =s+p; end; end; writeln(s); end.3)program cgt; var a: array[1..100,1..100]of integer; n,m,i,j,max,x,y: integer; beginread(n,m); for i: =1 to n dofor j: =1 to m doread(a[i,j]); max: =a[1,1]; for i: =1 to n doif(i mod 2=1)then beginfor j: =1 to m doif(a[i,j]> =max)then   beginmax: =a[i,j]; x: =i; y: =j; end; end; writeln(x,' ',y); end.
droshchupkin
Program cgt; var x1,y1,x2,a,y2,b,c,x3,y3: real; procedure ioi(x1,y1,x2,y2: real; var a: real); begin a: =sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2)); end; begin read(x1,x2,y1,y2,x3,y3); ioi(x1,y1,x2,y2,a); ioi(x1,y1,x3,y3,b); ioi(x3,y3,x2,y2,c); if(a> =b)and(a> =c)then writeln('первая и вторая точка ',a) else if(b> =a)and(b> =c)then writeln('первая и третая точка ',b) else if(c> =b)and(c> =a)then writeln('третая и вторая точка ',c); end.2)program cgt; var z,x,y: real; function ioi(x: real): real; beginif(x=0)then ioi: =0; if(x< 0)then ioi: =-1; if(x> 0)then ioi: =1; end; beginread(x,y); z: =(ioi(x)+ioi(y))*ioi(x+y); writeln(z); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая проверяет, является ли введенная с клавиатуры строка целым числом
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

NIKOLAI
afoninia
semenoffufc8
info36
avdushinalizza1
Petrakova Ilyushin
alfaantonk
Александра_Наталья1417
galustyanvitaly4842
Olesya-elena1525
many858
shumeikoElena362
Melnik Kaveshnikova1746
aleksey7800
mrFuz