verich
?>

Написать программу вычисления стоимости покупки с учетом скидки. скидка в 3% предостовляется, если сумма покупки больше 500 руб., в 5%-если сумма больше 1000 руб. исходные данные ввести с клавиатуры. вывод на экран должен быть в следующем виде: вычисление стоимости покупки с учетом скидки. введите сумму покупки- вам предостовляется скидка 3% сумма с учетом скидки: - или вам предоставляется скидка 5% сумма с учетом скидки: -

Информатика

Ответы

optikmir
If x> 500 than begin if x< 1000 than s: =x*0,03 else s: =x*0,05 end
Drugov_Vladimirovna
#include < iostream> #include < cmath> using namespace std; int main() { double one; int skid=0; cout< < "введите сумму покупки"< < endl; cin> > one; if(one> 500)  skid=5; else skid =3; cout< < "вам предоставляется скидка "< < skid< < "%"< < endl; cout< < "сумма покупки с учетом скидки: "< < double(skid)/100 * one < < endl; return 0; }
Елена Васильева839
Программа имеет линейную структуру, если все операторы (команды) выполняются последовательно друг за другом.                                                                                   командой повторения,   или  циклом,   называется такая форма организации действий в алгоритме, при которой выполнение одной и той же последовательности команд повторяется до тех пор, пока истинно некоторое логи­ческое выражение. различают циклы с известным числом повторений (цикл с параметром) и итерационные (с пред- и постусловием). обозначение каждого из видов циклов на блок-схемах алгоритмов. ^  ц  пц: = нз, кз, шикл с параметром цикл с предусловием цикл с постусловием  серия на схемах "серия" обозначает один или несколько любых операторов (команд); лв есть логическое вы­ражение (если его значение  истина,   переход проис­ходит по ветви, обозначенной  да,   иначе — по нет). на схеме цикла с параметром использованы обозна­чения: пц — параметр цикла, нз — начальное зна­чение параметра цикла, кз — конечное значение па­раметра цикла, ш — шаг изменения параметра цик­ла. серию команд, которые выполняются в цикле, называют  телом цикла.опишем схематично, как выполняется каждый из циклов. цикл с предусловием: а) вычисляется значение логического выражения; 6) если значение логического выражения  истина,  переход к следующему пункту, иначе к п. д); в) выполняется тело цикла; г) переход к п. а); д) конец цикла. цикл с постусловием: а) выполняется тело цикла; 6) вычисляется значение логического выражения; в) если значение логического выражения  ложь,   пере­ход к п. а), иначе к следующему пункту;   г) конец цикла.
batalerka391
Program cikli; unit math; var  i,n,s,p: integer;   a: array[1..20]of integer; begin  writeln('исходный массив: ');   for i: =1 to 20 do begin  a[i]: =randomrange(1,20);   writeln(' элемент ',i,' =  ',a[i]);   end;   writeln('сумму и произведения скольки первых чисел вы хотите посчитать? ');   readln(n);   s: =0; p: =1; //цикл с параметром  for i: =1 to n do begin  s: =s+a[i];   p: =p*a[i];   end; writeln('цикл с параметром'); writeln('сумма первых ',n,' чисел = ',s); writeln('произведения первых ',n,'чисел = ',p);   //цикл с предусловиемi: =1; p: =1; s: =0; while i< > n do begin  s: =s+a[i];   p: =p*a[i];   i: =i+1; end; writeln('цикл с предусловием'); writeln('сумма первых ',n,' чисел = ',s); writeln('произведения первых ',n,'чисел = ',p);   //цикл с постусловиемi: =0; s: =0; p: =1; repeat  i: =i+1;   s: =s+a[i];   p: =p*a[i]; until i=n; writeln('цикл с постусловием'); writeln('сумма первых ',n,' чисел = ',s); writeln('произведения первых ',n,'чисел = ',p); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления стоимости покупки с учетом скидки. скидка в 3% предостовляется, если сумма покупки больше 500 руб., в 5%-если сумма больше 1000 руб. исходные данные ввести с клавиатуры. вывод на экран должен быть в следующем виде: вычисление стоимости покупки с учетом скидки. введите сумму покупки- вам предостовляется скидка 3% сумма с учетом скидки: - или вам предоставляется скидка 5% сумма с учетом скидки: -
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Шиморянов Мария1866
kirill81
Vladstreletskiy
Хромов1501
Fedorovna
druzjkinaas22
proplenkusale88
kirillreznikov
Полковников_Милана
101110(2)-10-қа айналдыру​
dmitrievanata83538
Chutaeva381
Aleksei Aleksandrovna649
Баканова1415
svt5299
Andreevna_Grebenshchikova155