Femida76
?>

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор, пока сумма не превысит 500. определить число членов суммы. значение суммы и число ее членов вывести на экран с соответствующими комментариями.

Информатика

Ответы

rina394992
Вроде получилось:

var a,b,s:integer; 
begin
write('Числа = ');
for a:=1 to 100 do
begin
b:=a mod 3;
if (b = 0) then
begin
write(a,', ');
s:=s+a;
if((s > 500) and (s<520)) then break;
end;
end;
writeln('Сумма чисел = ', s);
end.

Результат:

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор,
ВалентиновичСуриковна1104
Const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
flag,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          flag:=1;
if flag=1 then
   writeln('Yes')
else
   writeln('N');
end.

вариант 2
const
n=10;m=7;
var
a:array[1..n,1..m]of integer;
k,i,j,b:integer;
begin
     for i:=1 to n do
         begin
             writeln;
                 for j:=1 to m do
                      begin
                        a[i,j]:=random(312)-111;
                        write(a[i,j]:4);
                      end;
            end;
writeln;
Writeln('B ?');
readln(b);
for i:=1 to n do
  for j:=1 to m do
      if a[i,j]=b then
          k:=k+1;
if k<>0 then
   writeln('Yes')
else
   writeln('N');
end.
volodin-alexander

/** libraries */

#include <iostream>

#include <cmath>

#include <vector>

#include <map>

#include <set>

#include <queue>

#include <stack>

#include <algorithm>

/** libraries */

using namespace std;

/** defines */

#define ll long long

#define ld long double

#define yes cout << "YES" << "\n"

#define no cout << "NO" << "\n"

/** defines */

int a[20];

void solve(){

   ld sum = 0;

   for(auto i: a)

       sum += i;

   ld av = sum / 20;

   int res = 0;

   for(auto i: a)

       if(i < av)

           res++;

   cout << res;

}

signed main() {

   ios_base::sync_with_stdio(false);

   cin.tie(nullptr);

   cout.tie(nullptr);

   for(int i = 0; i < 20; i++)

       cin >> a[i];

   solve();

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на паскале вычислить сумму чисел натурального ряда, делящихся на 3, до тех пор, пока сумма не превысит 500. определить число членов суммы. значение суммы и число ее членов вывести на экран с соответствующими комментариями.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

julichca68
Svetlana1877
dimiff5
krasilnikov74
chetverikovalex3738
tetralek
Belov
Gera8061
sky-elena712558
kuziv31
kostmax1971
BelozerovaGeller648
Калмыкова-Петрунина
Лифанов_Ольга
vit010916
▲