nikiforovako76
?>

Исполнитель май4 преобразует число, записанное на экране. у исполнителя три команды, которым присвоены номера: 1. прибавь 2 2. прибавь 3 3. прибавь 5 сколько есть программ, которые преобразуют число 20 в 35?

Информатика

Ответы

yuip2008
Для сло­же­ния спра­вед­лив пе­ре­ме­сти­тель­ный (ком­му­та­тив­ный) закон, зна­чит, по­ря­док ко­манд в про­грам­ме не имеет зна­че­ния для ре­зуль­та­та.
Все ко­ман­ды уве­ли­чи­ва­ют ис­ход­ное число, по­это­му ко­ли­че­ство ко­манд не может пре­вос­хо­дить (35 − 20)/2 = 7.
При этом ми­ни­маль­ное ко­ли­че­ство ко­манд — 3.Таким об­ра­зом, ко­манд может быть 3, 4, 5, 6 или 7. По­это­му по­ря­док ко­манд не имеет зна­че­ния, каж­до­му числу ко­манд со­от­вет­ству­ет один набор ко­манд, ко­то­рые можно рас­по­ло­жить в любом по­ряд­ке.
Рас­смот­рим все воз­мож­ные на­бо­ры и вы­чис­лим ко­ли­че­ство ва­ри­ан­тов рас­спо­ло­же­ния ко­манд в них.
Набор 1111112 имеет 7 воз­мож­ных ва­ри­антов.
Набор 111113 - 6 вариантов
Набор 111222 - 20 воз­мож­ных ва­ри­ан­тов рас­по­ло­же­ния: это число пе­ре­ста­но­вок с по­вто­ре­ни­я­ми 6!/(3!·3!).
Набор 22222 - 1 вариант
Набор 11322 -  30 воз­мож­ных ва­ри­ан­тов рас­по­ло­же­ния: это число пе­ре­ста­но­вок с по­вто­ре­ни­я­ми 5!/(2! * 1! * 2!).
Набор 3312 - 12 ва­ри­ан­тов: это число пе­ре­ста­но­вок с по­вто­ре­ни­я­ми 4!/(2!·1!·1!))
Набор 333 - 1 вариант.

Всего имеем: 7 + 6 + 20 + 1 + 30 + 12 + 1 = 77 про­грамм. ответ: 77.

Теперь все точно! )
Li-111

При его решении сначала вычисляют дискриминант по формуле.

Если D > 0, то квадратное уравнение имеет два корня; если D = 0, то 1 корень; и если D < 0, то делают вывод, что корней нет.

Если D > 0, то квадратное уравнение имеет два корня; если D = 0, то 1 корень; и если D < 0, то делают вывод, что корней нет.Таким образом, программа для нахождения корней квадратного уравнения может иметь три ветви условного оператора.

Если D > 0, то квадратное уравнение имеет два корня; если D = 0, то 1 корень; и если D < 0, то делают вывод, что корней нет.Таким образом, программа для нахождения корней квадратного уравнения может иметь три ветви условного оператора.Функция float() преобразует переданный ей аргумент в вещественное число.

vs617

1-е Задание:

Program PRG;

var

a, b, c, e, x, y, num, den: real;

function calc( a, b, c, e, x: real ): real;

begin

 num := ((( abs(sin(x ** 3))) + a) * (e ** a));

 den := (exp(ln((b ** 2) + (c ** 2)) / 3));

 y :=  num / den;

 Result := y;

 write('Answer is: ', y);

 writeln();

end;

function entNums (): real;

begin

 write ('Enter a: '); readln (a);

 write ('Enter b: '); readln (b);

 write ('Enter c: '); readln (c);

 write ('Enter e: '); readln (e);

 write ('Enter x: '); readln (x);

 writeln();

end;

begin

   entNums();

calc( a, b, c, e, x );

end.

2-е Задание:

Program  

var wallWid, wallHeight, winHeight, winWid, doorWid, doorHeight, fourWalls, door, win, total: real;

function getFourWalls( wallWid, wallHeight: real ): real;

   begin

       fourWalls := (wallHeight * wallWid) * 4;

       Result := fourWalls;

   end;

function getDoorSize( doorHeight, doorWid: real ): real;

   begin

       door := doorHeight * doorWid;

       Result := door;

   end;

function getWinSize( winHeight, winWid: real ): real;

   begin

       win := winHeight * winWid;

       Result := win;

   end;

function getWalls(): real;

   begin

       total := (fourWalls - ( door + win )) / 10000;

       Result := total;

       write(' You need ', total, ' m² of wallpaper!');

       writeln();

   end;

function enterSizes(): real;

   begin

       writeln();

       write (' Enter width of the wall (in cm): '); readln (wallWid);

 write (' Enter height of the wall (in cm): '); readln (wallHeight);

 write (' Enter width of the window (in cm): '); readln (winWid);

 write (' Enter hight of the window (in cm): '); readln (winHeight);

 write (' Enter width of the door (in cm): '); readln (doorWid);

 write (' Enter height of the doot (in cm): '); readln (doorHeight);

 writeln();

   end;

begin

   enterSizes();

   getFourWalls( wallWid, wallHeight );

   getDoorSize( doorHeight, doorWid );

   getWinSize( winHeight, winWid );

   getWalls();

end.

Блок-схемы легко можешь составить глядя на коды программ)

Удачи)

 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Исполнитель май4 преобразует число, записанное на экране. у исполнителя три команды, которым присвоены номера: 1. прибавь 2 2. прибавь 3 3. прибавь 5 сколько есть программ, которые преобразуют число 20 в 35?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

murza2007
slipu817838
Alsergus7811
Никитина580
Шиморянов Мария1866
uchpapt
dinadumno2114
mikchaylovaalex
Timurr007
elenalukanova
generallor3
Aleksandr72
irinalav2705745
Равилевич_Олеговна1496
Suralevartem
▲