vera-spicina
?>

На языке си. напишите программу, которая получает два целых числа a и b (0 < a < b) и выводит квадраты всех натуральных чисел в интервале от a до b. пример: введите два целых числа: 10 12 10*10=100 11*11=121 12*12=144

Информатика

Ответы

Natella-874535
#include <iostream>
#include <conio.h>
using namespace std;

int main()
{
    setlocale(LC_ALL,"Russian");
    unsigned long long A,B;
    cout << "Введите A(Начало) и B(Конец):\t";
    cin >> A >> B;
    if (A>0)
        for (unsigned long long i=A; i<=B; i++)
            cout << i << "\t - \t" << i*i << endl;
    else
    {
        cout << "Ошибка!";
        _getch();
        return -1;
    }
    _getch();
    return 0;
}

P.S. Это моя старая программа на C++, ПИСАЛ ЕЁ ДАВНО, использовал Microsoft Visual C++ 2010.
Andrei_Mariya

1.

использовать Чертежник

алг

нач

выбрать чернила (красный)

сместиться в точку (1, 1)

опустить перо

сместиться в точку (4, 7)

сместиться в точку (5, 7)

сместиться в точку (8, 1)

сместиться в точку (7, 1)

сместиться в точку (6.2,2.5)

сместиться в точку (2.8,2.5)

сместиться в точку (2, 1)

сместиться в точку (1, 1)

поднять перо

сместиться в точку (3.3,3.5)

опустить перо

сместиться в точку (5.7,3.5)

сместиться в точку (5, 5)

сместиться в точку (4, 5)

сместиться в точку (3.3,3.5)

поднять перо

сместиться в точку (0, 0)

кон

2.

использовать Чертежник

алг

нач

сместиться в точку (2.7,1)

опустить перо

сместиться в точку (6,9.8)

сместиться в точку (9.3,1)

сместиться в точку (1,6)

сместиться в точку (11,6)

сместиться в точку (2.7,1)

поднять перо

сместиться в точку (0,0)

кон

3.

использовать Чертежник

алг

нач

сместиться в точку (3,7)

нц 5 раз

опустить перо

сместиться на вектор (0,-2)

сместиться на вектор (-2,0)

поднять перо

сместиться на вектор (3,1)

кц

сместиться в точку (0,0)

кон

Объяснение:

Смотри картинки


Выполнить в КУМИРе: 1. Начертите красным цветом контур буквы «А». Размеры буквы – произвольные. 2.
Выполнить в КУМИРе: 1. Начертите красным цветом контур буквы «А». Размеры буквы – произвольные. 2.
Выполнить в КУМИРе: 1. Начертите красным цветом контур буквы «А». Размеры буквы – произвольные. 2.
kuchin

1.

использовать Чертежник

алг

нач

выбрать чернила (красный)

сместиться в точку (1, 1)

опустить перо

сместиться в точку (4, 7)

сместиться в точку (5, 7)

сместиться в точку (8, 1)

сместиться в точку (7, 1)

сместиться в точку (6.2,2.5)

сместиться в точку (2.8,2.5)

сместиться в точку (2, 1)

сместиться в точку (1, 1)

поднять перо

сместиться в точку (3.3,3.5)

опустить перо

сместиться в точку (5.7,3.5)

сместиться в точку (5, 5)

сместиться в точку (4, 5)

сместиться в точку (3.3,3.5)

поднять перо

сместиться в точку (0, 0)

кон

2.

использовать Чертежник

алг

нач

сместиться в точку (2.7,1)

опустить перо

сместиться в точку (6,9.8)

сместиться в точку (9.3,1)

сместиться в точку (1,6)

сместиться в точку (11,6)

сместиться в точку (2.7,1)

поднять перо

сместиться в точку (0,0)

кон

3.

использовать Чертежник

алг

нач

сместиться в точку (3,7)

нц 5 раз

опустить перо

сместиться на вектор (0,-2)

сместиться на вектор (-2,0)

поднять перо

сместиться на вектор (3,1)

кц

сместиться в точку (0,0)

кон

Объяснение:

Смотри картинки


Выполнить в КУМИРе: 1. Начертите красным цветом контур буквы «А». Размеры буквы – произвольные. 2.
Выполнить в КУМИРе: 1. Начертите красным цветом контур буквы «А». Размеры буквы – произвольные. 2.
Выполнить в КУМИРе: 1. Начертите красным цветом контур буквы «А». Размеры буквы – произвольные. 2.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На языке си. напишите программу, которая получает два целых числа a и b (0 < a < b) и выводит квадраты всех натуральных чисел в интервале от a до b. пример: введите два целых числа: 10 12 10*10=100 11*11=121 12*12=144
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

aggeeva
valentinakarma2800
Nadezhda Malakhov53
savva-vika
Юлия1689
superkiosk249
СмыковаДарья1969
evsmorodina
koam20167459
Elizavetaborisovna1992
suhanowaswetlana
snabdonm501
Svetlana1884
Мусаев Игоревич371
vbnm100584