mulyugina365
?>

Ручка стоит к рублей. первого сентября стоимость ручки увеличилась ровно на р процентов. определите, сколько ручек можно купить на s рублей после подорожания. программа получает на вход три целых положительных числа.первое число к-стоимость ручки в рублях до подорожания. второе число р - величина подорожания ручки в процентах. третье число s- имеющаяся сумма денег. числа к и s не превосходят 10 в 7 степени , число р не превосходит 100. решать только в ! решения на паскале не !

Информатика

Ответы

Баранов276
K=float(input())
p=float(input())
s=float(input())
k=k*(1+p/100)
print(int(s/k))
msk27
K = int(input())
p = int(input())
s = int(input())
n = k*100 + p*k 
g = s*100 // n
print (g)

Попробуй так, я сама еще не про, но все же
Корнеплодович1930
2) 100001100 = 2^8 + 2^3 + 2^2 = 256 + 8 + 4 = 268
3) 137 = 10001001 (нужно число делить на 2, записывая остаток, и так до тех пор пока число уже нельзя будет делить, потом записываем остатки в обратном порядке)
137 / 2 = 68 ( остаток 1)
68 / 2 = 34 (остаток 0)
34 / 2 = 17 (остаток 0)
17 / 2 = 8 (остаток 1)
8 / 2 = 4 (0)
4 / 2 = 2 (0)
2 / 2 = 1 (0)
Теперь записываем остатки в обратном порядке = 10001001
4) Как я понял 8 и 16 это систему счисления, если да то:
а)151 = 1 * 8^2 + 5 * 8^1 + 1 * 8^0 = 64 + 40 + 1 = 105
б) 2С = 2 * 16 + 12(С) = 32 + 12 = 44
Ushakova Sakhno
Uses crt;
var
    b, a: real;
    n: integer;

begin
    clrscr;
    repeat
        Write('Выберите фигуру (1-квадрат, 2-прямоугольник)');
        Readln(n);
        
        case n of
            1:
                begin
                    write('Сторона квадрата=');
                    readln(a);
                    Write('S=', a * a);
                end;
            2:
                begin
                    write('Стороны прямоугольника=');
                    readln(b, a);
                    Write('S=', b * a);
                end;
        else exit;
        end;
    until false;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ручка стоит к рублей. первого сентября стоимость ручки увеличилась ровно на р процентов. определите, сколько ручек можно купить на s рублей после подорожания. программа получает на вход три целых положительных числа.первое число к-стоимость ручки в рублях до подорожания. второе число р - величина подорожания ручки в процентах. третье число s- имеющаяся сумма денег. числа к и s не превосходят 10 в 7 степени , число р не превосходит 100. решать только в ! решения на паскале не !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Boss5519
ebelskaia
kirieskamod262
VladimirovnaSimonov
orinvarostov
Prostofil200790
Жуков219
Stasyadoma
Lorvi_Shevkunova849
snip99
yna21289
byfetvostochniy
tanyashevvvv
samsakovs7757
Yelena1458