Мамедов
?>

Напишите на паскале. : написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом r

Информатика

Ответы

baton197310
Var a,b,c,r,s,p: real;
begin
  write('длины сторон треугольника a,b,c через пробел: ');
  readln(a,b,c);
  write('радиус круга r: ');  readln(r);
  p:=(a+b+c)/2;
  s:=sqrt(p*(p-a)*(p-b)*(p-c));
  if r>=(a*b*c)/(4*s) then writeln('можно поместить')
  else writeln('нельзя поместить');
end.

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.49
нельзя поместить

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.5
можно поместить
Хохлова Иванович

1. Человек воспринимает информацию о тембре голоса с

4) слуха

2. Не является действием с информацией:

3) покраска окон

4. Действия по обработке информации:

3) перевод текста

Человек воспринимает информацию о форме листьев с

3) зрения

6. Не является действием с информацией:

1) участие в забеге

9.Тактильную информацию человек получает посредством

d. органов осязания.

10.Информация – это…

c) сведения об окружающем мире и протекающих в нем процессах, воспринимаемые человеком непосредственно или с специальных устройств

Natysya7777

113 в 10 СС = 1110001 в 2 СС

113 в 10 СС = 305 в 6 СС

113 в 10 СС = 71 в 16 СС

Объяснение:

113 / 2 = 56 + остаток 1

56 / 2 = 28 + остаток 0

28 / 2 = 14 + остаток 0

14 / 2 = 7 + остаток 0

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

113 в 10 СС = 1110001 в 2 СС

113 / 6 = 18 + остаток 5

18 / 6 = 3 + остаток 0

3 / 6 = 0 + остаток 3

записываем остатки снизу вверх

113 в 10 СС = 305 в 6 СС

113 / 16 = 7 + остаток 1

7 / 16 = 0 + остаток 7

записываем остатки снизу вверх

113 в 10 СС = 71 в 16 СС

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите на паскале. : написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом r
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sharikplushelen
semenoffufc8
denisrogachv
e90969692976
oafanasiev41
omigunova39
nofate1016585
Максим Павел
zakaz
gorodof4292
Геннадьевна
titovass9
xarfagr
olimov9
Igor120