pastore
?>

Написать программу в free pascal'e, ! условие: пусть k - целое от 1 до 365. присвоить целой переменной n значение 1, 2, 6 или 7 в зависимости от того, на какой день недели (понедельник, вторник, субботу или воскресенье) приходится k-й день не високосного года, в котором 1 января - понедельник.

Информатика

Ответы

iralkap
Var k,n:integer;
begin
write('k = ');
readln(k);
n:=(k-1) mod 7+1;
writeln('n = ',n);
end.

Пример:
k = 21
n = 7
ipeshindina236
Не хватает либо цены за билет эконом класса
либо цены за билет бизнес класса.

Uses crt;
var a,b,x,c,d:real;
begin
ClrScr;
writeln('Введите кол-во нераспроданных билетов бизнес класса (а) и кол-во нераспроданных билетов эконом. класса (б) ');
readln(a,b);
// Узнали, сколько осталось нераспроданных билетов разных классов.
c:=160*0.75-b;
// Узнали, сколько билетов продано эконом класса.
d:=160*0.25-a;
// Узнали, сколько билетов продано бизнес класса.
x:=d+c/2;
writeln('Для того, чтобы узнать сколько денег получила авиакомпания за этот рейс нужно число х: ',x,' умножить на цену билета бизнес класса, либо умножить на удвоенную цену одного билета эконом класса');
readln
end.

Или ответ: число которое выведет программа х, например, ответ: 15х

Программа проверена, если что не так пиши
kryshtall2276
Romanf romanf отличник 2013-01-10t16: 13: 22+00: 00 1. подумать над алгоритмом 2. вот сам алгоритм: а. спросить у пользователя значения б. расчитать ответ в. выдать ответ на экран 3. написать код в паскале 4. исправить ошибки компиляции 5. протестировать, вводить разные числа 6. обнаружила, что если вводить числа наугад ответ получается отрицательным иногда 7. вставить код проверки введенных пользователем значений 8. убрать ошибки компиляции 9. протестировать 10. готово а вот и сама программа: program aerobus; uses crt; const totalplace = 160; var businessplaces, economyplaces: integer; businessprice, economyprice: real; totalcharge: real; a,b: integer; correctinput: boolean; begin clrscr; businessplaces: =totalplace div 4; economyplaces: = totalplace - businessplaces; writeln('business places count: ', businessplaces); writeln('economy places count: ', economyplaces); correctinput: =false; while not correctinput do begin write('please input business class ticket price: '); readln(businessprice); if(businessprice> 0) then begin correctinput: =true; end else begin writeln('the price should be a positive number, please try again'); end; end; economyprice: =businessprice/2; writeln('economy ticket price is: ', economyprice: 0: 2); correctinput: =false; while not correctinput do begin write('how many business tickets are left? : '); readln(a); if(a> =0) and (a< =businessplaces)then correctinput: =true; if(a< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(a> businessplaces) then begin writeln('please input a number which is less or equal to the tolal business place count, please try again'); end; end; correctinput: =false; while not correctinput do begin write('how many economy tickets are left? : '); readln(b); if(b> =0) and (b< =economyplaces)then correctinput: =true; if(b< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(b> economyplaces) then begin writeln('please input a number which is less or equal to the tolal economy place count, please try again'); end; end; totalcharge: =(businessplaces-a)*businessprice; totalcharge: =totalcharge+(economyplaces-b)*economyprice; writeln('the total charge is: ', totalcharge: 0: 2); writeln; writeln('press enter to exit'); readln; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в free pascal'e, ! условие: пусть k - целое от 1 до 365. присвоить целой переменной n значение 1, 2, 6 или 7 в зависимости от того, на какой день недели (понедельник, вторник, субботу или воскресенье) приходится k-й день не високосного года, в котором 1 января - понедельник.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

araqsyabadalyan1988
elhovskoemodk
sonicegle
Исмагилова_Саният
Fedorovich309
Anastasiya Yevseeva948
vvb1383
bochkarevazh
gorbelena1971
gbelihina
Александрович784
Varezka86179
mariapronina720126
Sergei
mbudilina