georgegradoff122
?>

Дано целое двузначное положительное число n . составьте программу, которая определяет, входят ли в него цифры 2 и 5

Информатика

Ответы

Sukharev-Achkasov
Var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if (a1=2)or(a2=2)
 then writeln('В числе есть цифра 2');
if (a1=5)or(a2=5)
 then writeln('В числе есть цифра 5');
if (a1<>2)and(a2<>2)and(a1<>5)and(a2<>5)
 then writeln('В числе нет цифр 2 и 5');
end.

Пример:
a = 25
В числе есть цифра 2
В числе есть цифра 5
denisdenisov63
Компьютерные сети – это системы компьютеров, объединенных каналами передачи данных, обеспечивающие эффективное предоставление различных информационно-вычислительных услуг пользователям посредством реализации удобного и надежного доступа к ресурсам сети.Информационные системы, использующие возможности компьютерных сетей, обеспечивают выполнение следующих задач:·        Хранение и обработка данных·        Организация доступа пользователей к данным·        Передача данных и результатов обработки   решения перечисленных задач обеспечивается:·        Дистанционным доступом пользователей к аппаратным, программным и информационным ресурсам·        Высокой надежностью системы·        возможностью оперативного перераспределения нагрузки·        специализацией  отдельных узлов сети для решения определенного класса задач·        решением сложных задач совместными усилиями нескольких узлов сети·        возможностью осуществления оперативного контроля всех узлов сети
fhf3624
В Java есть 5 или 6 - вида диалоговых окон:
JOptionPane.showMessageDialog('значение где расположется окно', 'сам текст'); - обычное окно с сообщением.
JOptionPane.showInputDialog('Текст'); - окно в котором вводится одно значения
JOptionPane.showMessageDialog('расположение','текст','имя окна',PLAIN_MESSAGE); - Это окно с сообщением, которое без изображения, пустое окно, так как самое первое окно - показывает значок информации.
JOptionPane.showMessageDialog('расположение','текст','имя окна',ERROR_MESSAGE); - окно с значком ошибки
JOptionPane.showMessageDialog('расположение','текст','имя окна',WARNING_MESSAGE); - окно с предупреждением

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое двузначное положительное число n . составьте программу, которая определяет, входят ли в него цифры 2 и 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

reinish23
sanina611
gbelihina
Мирзоев Денис
Stepanovich_Makarov
kirillboytsov403
legezin
dariamay1996
daarisgoy
nickcook424
puma802
rs90603607904
okasnab
thecoffeeowl
yatania-popovich7
▲