Пользователь знает ключ, или
пароль, который известен только ему. К этой группе можно отнести и идентификацию через смс-уведомления. При вводе имени и пароля пользователя сервер сравнивает введенные данные
с сохраненными данными. В случае полной идентичности введенных данных появляется возможность войти в систему.
Различают два вида паролей – динамические
и постоянные. Постоянные пароли изменяются
только по требованию пользователя, а динамические пароли изменяются по определенным параметрам. Например, если пользователь забудет
пароль, сервер может предложить ему динамический пароль для входа в систему.
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Выясните лучший результат в соревнованиях по плаванию для n спортсменов и фамилию этого спортсмена. написать программу в хотя бы идею
// PascalABC.NET 3.3, сборка 1531 от 30.08.2017
// Внимание! Если программа не работает, обновите версию!
begin
var L:=new List<(string,real)>;
// это не решение задачи, это ввод данных
Writeln('Введите в каждой строке фамилию, пробел, время');
var i:=1;
repeat
var s:=ReadlnString(i+': ');
if s[1]='*' then break;
var w:=s.ToWords;
L.Add(Rec(w[0],real.Parse(w[1])));
i+=1;
until false;
// а теперь само решение
Writeln(L.MinBy(x->x[1]))
end.
Пример
Введите в каждой строке фамилию, пробел, время
1: Иванов 10.3
2: Петров 9.9
3: Уточкин 10.1
4: *
(Петров,9.9)