topsalon
?>

Составить программу для вычисления значения функции z(a): 1, если а> 0, z=0, если а=0, -1, если a< 0. (на языке с просто) ()

Информатика

Ответы

armentamada1906

#include <stdio.h>

int main()

{

   float a;

   int z;

   scanf("%f", &a);

   if (a>0) z=1;

   else if (a==0) z=0;

   else z=-1;

   printf("%d", z);

   return 0;

}

svetsalikowa

1. В)

2. Б)

3. Г)

4. Б)

5. А), В)

6. Г)

7. А) животные, Б) одежда, В) слова, Г) деревья, Д)кисломолочные продукты, Е) цифры.

8. Ещё подумаю

9. 1) макароны, 2) песня, 3) песок, 4)шарф.

10. Например: 1) 5; 2) 5×5=25; 3)25×2=50; 4) 50+4=54; 5) 54-8=46; 6) 6; 7) 6×7=42; 8) 42:2=21 и 1) 3; 2) 3×5=15; 3) 15×2=30; 4)30+4=34; 5)34-8=26; 6) 6; 7)6×7=42; 8)42:2=21

Вывод: если взять любое число кроме нуля и выполнить с ним эту последовательность действий, то получается одно и тоже число-21.

11. 1) Раньше всех пришла лиса.

2) 1 - Лиса, 2 - медведь, 3 - заяц, 4 - волк, 5 - сорока.

12. Вариант - 1

1. В ведро вместимостью 8 л налить 5 л.

2. В банку вместимостью 5 л налить 2 л.

Вариант - 2

Ведро вместимостью 8 л налить 7 л.

anna241273

1. В)

2. Б)

3. Г)

4. Б)

5. А), В)

6. Г)

7. А) животные, Б) одежда, В) слова, Г) деревья, Д)кисломолочные продукты, Е) цифры.

8. Ещё подумаю

9. 1) макароны, 2) песня, 3) песок, 4)шарф.

10. Например: 1) 5; 2) 5×5=25; 3)25×2=50; 4) 50+4=54; 5) 54-8=46; 6) 6; 7) 6×7=42; 8) 42:2=21 и 1) 3; 2) 3×5=15; 3) 15×2=30; 4)30+4=34; 5)34-8=26; 6) 6; 7)6×7=42; 8)42:2=21

Вывод: если взять любое число кроме нуля и выполнить с ним эту последовательность действий, то получается одно и тоже число-21.

11. 1) Раньше всех пришла лиса.

2) 1 - Лиса, 2 - медведь, 3 - заяц, 4 - волк, 5 - сорока.

12. Вариант - 1

1. В ведро вместимостью 8 л налить 5 л.

2. В банку вместимостью 5 л налить 2 л.

Вариант - 2

Ведро вместимостью 8 л налить 7 л.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для вычисления значения функции z(a): 1, если а> 0, z=0, если а=0, -1, если a< 0. (на языке с просто) ()
Ваше имя (никнейм)*
Email*
Комментарий*