Bsn1704
?>

Pascalabcnet : ввести и упорядочить последовательность из n натуральных чисел таким об-разом, чтобы она возрастала до середины, а затем убывала.

Информатика

Ответы

lshimina65
// PascalABC.NET 3.3

begin
  var n:=ReadInteger;
  var a:=ArrRandom(n,10,90); a.Println;
  a:=a[0:n div 2].Sorted.ToArray+a[n div 2:n].SortedDescending.ToArray;
  a.Println;
end.

Пример:
10
82 83 53 79 31 34 24 66 47 44
31 53 79 82 83 66 47 44 34 24
kseniay2006548
PascalABC.NET 3.3.5, сборка 1644 от 23.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ArrRandom(n,-50,60); a.Println;
  (a[:n div 2].OrderBy(t->t)+a[n div 2:].OrderByDescending(t->t)).Println
end.

Пример
n= 10
53 -39 49 22 -18 40 -40 -9 -16 0
-39 -18 22 49 53 40 0 -9 -16 -40
kormilitsynarita
//Блок-схемы в приложении
//Pascal ABC.NET v3.0 сборка 1111

//1
Var
 a,p,s:real;
begin
readln(a);
p:=a*4;
s:=a*a;
writeln('P=',p);
writeln('S=',s);
end.

//2
Var
 a,b:integer;
begin
 read(a,b);
 if a>b then writeln(b);
 if a=b then writeln('=');
 if a<b then writeln(a);
end.

{На этом и закончу всем, кто когда либо и чем либо поддерживал данный проект. Думаю, он ещё многим послужит в критический момент. И я говорю не только про "списать домашку". Счастливо оставаться, господин Alviko. Может, ещё увидимся.
Ваш, Глеб 'I3artle' Косырев}
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
1)написать программу, вычисляющую площадь и периметр квадрата. сторона- число вещественное. предвари
Татьяна902
1. 2 Массивы объявляются тем же оператором, что и обычные переменные
2. Не корректный вопрос: индекс - это обращения к определенному элементу массива, а у самого массива индекса нет. В вариантах ответа ничего похожего на это нет.
3. 4 Массивы заполняются теми же операторами, что и обычные переменные
4. 1 Есть такой ввода в бейсике - конструкция READ DATA
5. 1 Выведется четвертый элемент массива, т.к. нумерация идет с нуля, и первый имеет номер 0, второй - 1, третий - 2, а четвертый - номер 3, который и запрашивается в выражении А(3)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascalabcnet : ввести и упорядочить последовательность из n натуральных чисел таким об-разом, чтобы она возрастала до середины, а затем убывала.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

amarantmetall
Рамиль211
makscska22879
kol-nat26
Akopovich802
abahtina582
Альберт Татьяна
Konchenko1980
Гаврилаш
goryavinan
Павел
Альберт Луиза1595
ak74-81
vladimirkirv
jurys71242
▲